Bug 66698 - package db1 does not enable "-ldb1" linking
Summary: package db1 does not enable "-ldb1" linking
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: db1 (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-13 19:03 UTC by Hans Ecke
Modified: 2013-07-02 22:55 UTC (History)
1 user (show)

Fixed In Version: db4-4.3.27-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-15 12:26:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans Ecke 2002-06-13 19:03:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020612

Description of problem:
According to the usual semantics, one would expect that

* the "db1" package is usefull to execute applications linked with -ldb1 and
link binary object files (or libraries) together to an application with "-ldb1"

* the "db1-devel" package is usefull to _compile_ sourcecode that makes use of
the Berkeley DB interface.

The packages as they stand now allow only execution with the "db1" package.
Linking and compilation depend on the "db1-devel" package.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install "db1", deinstall "db1-devel"
2.try to link an application where one of the constituents (i.e. gnome
libraries) needs db1. Try for instance to compile recent galeon SRPM.
3.Get a linker error: "cannot find -ldb1"
	

Actual Results:  Linking not possible because linker can't find libdb1.so or
libdb1.a.

Notice that no db1 _header_files_ are involved.

Expected Results:  Linker should find libdb1.so and link.

Additional info:

Fix: in the "db1" package, include the link /usr/lib/libdb1.so ->
/usr/lib/libdb1.so.2 which currently resides in "db1-devel"

Comment 1 Jindrich Novy 2006-02-15 12:26:12 UTC
This problem doesn't seem to happen with more recent db version (db4).


Note You need to log in before you can comment on or make changes to this bug.