Bug 66702 - RH7.1 kickstart failing with "no valid block devices found"
RH7.1 kickstart failing with "no valid block devices found"
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-13 16:43 EDT by Ellen Williamson
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-14 12:07:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ellen Williamson 2002-06-13 16:43:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
During a RH7.1 kickstart, "An error has occurred - no valid devices were found
on which to create new filesystems. Please check your hardware for the cause of
this problem."

ks.cfg:
#Generated by Kickstart Configurator
device scsi --opts=aic7xxx
clearpart --all
lang en_US
keyboard us
mouse generic3ps/2
timezone --utc America/Denver
rootpw --iscrypted <my encrypted password>
lilo --location mbr
url --url ftp://<my ftp server>/pub
install

firewall --disabled 
zerombr yes
part /boot  --size 23
part swap --size 2047
part swap --size 2047
part /  --size 258
part /var  --size 1200
part /tmp  --size 1043
part /usr  --size 2055
network --bootproto static  --ip <my ipaddress>  --netmask 255.255.255.0 
--gateway <my gateway>  --nameserver <my nameserver>
auth --useshadow --enablemd5 --enablenis --nisdomain <my domain>

%packages 
@GNOME
@Kernel Development
@Networked Workstation
@Printer Support
@X Window System

** I can install fine from cdrom.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Place kickstart diskette in floppy drive
2.Boot
3.
	

Additional info:
Comment 1 Michael Fulbright 2002-06-14 11:50:10 EDT
Does an intereactive install work?

Could you possibly use the 7.3 release? It has alot of bug fixes.
Comment 2 Ellen Williamson 2002-06-14 12:07:01 EDT
Yes, an install from cd works fine.

Most companies do not have the luxury of changing OS everytime a new one comes 
out.  We have almost 50 linux servers in 7 different sites.  It's a bad idea in 
a production environment to throw the latest OS on a system that is currently 
working for an engineering team attempting to meet schedule deadlines.  The 
only reason I am installing this OS now is to add X Windows which I originally 
didn't think we needed, but it turns out we do.

fyi, I recently installed 7.2 on two of these Dell 1550 systems and immediately 
lost all NFS access, so went back to the OS that worked for me.  System admin. 
in a different location tried installing 7.3 on a Dell 2550 and it began 
sending tons of NFS broadcast traffic, completely hosing their network.  Again, 
they returned to the last known good OS.  (In their case, it was 7.2!)  

So, unfortunately, going to 7.3 is not an option for me.  If you don't want to 
fix this, I'll just reinstall all 10 systems by cd.

Just for future reference, does this mean that unless I have a bug with the 
latest RH OS, I shouldn't bother to file a bug report?
Comment 3 Michael Fulbright 2002-06-20 11:56:11 EDT
We do not actively backport fixes to previous releases of the Red Hat Linux
product.  We roll our fixes into the next release.  The Red Hat Advanced Server
product aims for a longer (> 12month) support cycle, and is probably better for
what you're looking at.

Note You need to log in before you can comment on or make changes to this bug.