Bug 667062 - add support for sansa fuze+
add support for sansa fuze+
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-04 04:40 EST by Jiri Moskovcak
Modified: 2015-02-01 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-31 18:02:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add support for few new devices (13.03 KB, patch)
2011-01-04 04:44 EST, Jiri Moskovcak
no flags Details | Diff

  None (edit)
Description Jiri Moskovcak 2011-01-04 04:40:01 EST
Description of problem:
my sansa fuze+ is not recognized by libmtp in Fedora

Version-Release number of selected component (if applicable):
libmtp-1.0.3-6

How reproducible:
100%

Steps to Reproduce:
1. connect sansa fuze+ to pc
2. run mtp-detect or mtp-connect

  
Actual results:
error message saying something about UKNOWN id pops out, suggesting me to contact libmtp devels...

Expected results:
fuze+ working over MTP

Additional info:
there is a patch in Ubuntu package which adds support for this player
Comment 1 Jiri Moskovcak 2011-01-04 04:44:40 EST
Created attachment 471626 [details]
patch to add support for few new devices

  * New devices:
    - Nokia 2710 0421:02c1.
    - Nokia 5230 0421:02e2.
    - SanDisk Sansa Fuze+ 0781:74e0
    - Sony Walkman NWZ-B153F 054c:04be
    - Sony Walkman NWZ-E354 054c:04cb

I tested just the support for sansa fuze+ and it seems to work
Patch was created against the Fedora git.
Comment 2 Linus Walleij 2011-01-04 11:14:11 EST
Wella the proper thing for me to do is roll a new release of libmtp I think (since I'm the libmtp maintainer too...)
Comment 3 Jiri Moskovcak 2011-01-05 05:36:58 EST
(In reply to comment #2)
> Wella the proper thing for me to do is roll a new release of libmtp I think
> (since I'm the libmtp maintainer too...)

Even better ;)

Thank you.

Note You need to log in before you can comment on or make changes to this bug.