Bug 667363 - rhn-setup-1.0.0-38.el6: __strncmp_ssse3: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
rhn-setup-1.0.0-38.el6: __strncmp_ssse3: Process /usr/bin/python was killed b...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-dmidecode (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Roman Rakus
Petr Sklenar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-05 07:40 EST by prashant ingale
Modified: 2014-01-12 19:13 EST (History)
9 users (show)

See Also:
Fixed In Version: python-dmidecode-3.10.13-1.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, when running the rhn_register utility, providing a valid user name and password, and clicking the Forward button, the tool terminated unexpectedly with a segmentation fault. This was caused by the dmi_processor_id() function not checking whether the version pointer was NULL. This update adds additional checks for NULL values, fixing the problem.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 06:53:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (35.53 KB, text/plain)
2011-01-05 07:41 EST, prashant ingale
no flags Details

  None (edit)
Description prashant ingale 2011-01-05 07:40:25 EST
Description of problem:

cmdline: /usr/bin/python /usr/sbin/rhn_register
executable: /usr/bin/python
crash_function: __strncmp_ssse3
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)

Version-Release number of selected component (if applicable):

kernel: 2.6.32-71.el6.x86_64
package: rhn-setup-1.0.0-38.el6
release: Red Hat Enterprise Linux Server release 6.0 (Santiago)

How reproducible:
randomly

Steps to Reproduce:
1. Login as root
2. start rhn_register
3. enter valid user name/password and click next

Actual results:
rhn_register crash

Expected results:
rhn_register should not crash
Additional info:
Comment 1 prashant ingale 2011-01-05 07:41:12 EST
Created attachment 471844 [details]
backtrace
Comment 2 prashant ingale 2011-01-05 07:41:54 EST
Created attachment 471845 [details]
sosreport
Comment 4 David Sommerseth 2011-01-05 08:42:45 EST
This one is the same as bug #596264.  A fix is proposed there for RHEL5.6.

Just a little double check, which version of python-dmidecode is RHEL6 shipping with?
Comment 5 prashant ingale 2011-01-06 03:54:58 EST
Rhel6 has a python-dmidecode-3.10.12-1.el6.x86_64
Comment 6 David Sommerseth 2011-01-06 10:58:02 EST
See bug #596264 and especially attachment #472083 [details] for more a solution.  All patches in the attachment have been sent upstream already and is needed in python-dmidecode-3.10.12.
Comment 10 Roman Rakus 2011-06-29 12:34:26 EDT
Fixed in python-dmidecode-3.10.13-1.el6
Comment 12 Eliska Slobodova 2011-07-25 10:59:02 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, when running the rhn_register utility, providing a valid user name and password, and clicking the Forward button, the tool terminated unexpectedly with a segmentation fault. This was caused by the dmi_processor_id() function not checking whether the version pointer was NULL. This update adds additional checks for NULL values, fixing the problem.
Comment 14 errata-xmlrpc 2011-12-06 06:53:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1589.html

Note You need to log in before you can comment on or make changes to this bug.