Bug 667477 - firefox-4.0-0.8b8.fc15.x86_64 don't work
firefox-4.0-0.8b8.fc15.x86_64 don't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
x86_64 Unspecified
low Severity high
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 668029 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-05 13:18 EST by dominique
Modified: 2011-01-07 14:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-06 05:01:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dominique 2011-01-05 13:18:40 EST
Today there is an update to firefox-4.0-0.8b8.fc15.x86_64, and firefox don't work.
In console I have this error message:

[dominique@localhost ~]$ firefox
Error: /usr/lib64/firefox-4/firefox not found
       /usr/lib/firefox-4/firefox not found

I downgrade to firefox-4.0-0.7b8.fc15.x86_64 and firefox work.
Comment 1 Berrehouc Nicolas 2011-01-05 14:57:12 EST
Same problem after update to firefox-4.0-0.8b8.fc15.i686

$ firefox
Error: /usr/lib/firefox-4/firefox not found

$ ls /usr/lib/firefox-4/
chrome/      defaults/      icons/      modules/      searchplugins/
components/  extensions/    langpacks/  run-mozilla.sh
Comment 2 Martin Stransky 2011-01-05 15:50:22 EST
It's supposed to be launched by /usr/bin/firefox...what happens when you run it with full path?
Comment 3 Ray Strode [halfline] 2011-01-05 16:49:59 EST
$ sh -x /usr/bin/firefox
++ basename /usr/bin/firefox
+ cmdname=firefox
++ uname -m
+ MOZ_ARCH=x86_64
+ case $MOZ_ARCH in
+ MOZ_LIB_DIR=/usr/lib64
+ SECONDARY_LIB_DIR=/usr/lib
+ '[' '!' -x /usr/lib64/firefox-4/firefox ']'
+ '[' '!' -x /usr/lib/firefox-4/firefox ']'
+ echo 'Error: /usr/lib64/firefox-4/firefox not found'
Error: /usr/lib64/firefox-4/firefox not found
+ '[' -d /usr/lib ']'
+ echo '       /usr/lib/firefox-4/firefox not found'
       /usr/lib/firefox-4/firefox not found
+ exit 1

$ stat /usr/lib*/firefox-4/firefox
stat: cannot stat `/usr/lib*/firefox-4/firefox': No such file or directory
Comment 4 Bill Nottingham 2011-01-05 16:57:25 EST
Commenting out the checks for /usr/lib*/firefox-4/firefox in /usr/bin/firefox makes it work ok.
Comment 5 Matěj Cepl 2011-01-05 19:17:54 EST
(In reply to comment #4)
> Commenting out the checks for /usr/lib*/firefox-4/firefox in /usr/bin/firefox
> makes it work ok.

Not exactly on x86_64:

+ exec /usr/lib/firefox-4/run-mozilla.sh /usr/bin/xulrunner /usr/lib/firefox-4/application.ini
firefox: line 264: /usr/lib/firefox-4/run-mozilla.sh: No such file or directory
firefox: line 264: exec: /usr/lib/firefox-4/run-mozilla.sh: cannot execute: No such file or directory
jakoubek:bin# 

It should be /usr/lib64/firefox-4.
Comment 6 Martin Stransky 2011-01-06 05:01:03 EST
Should be fixed in firefox-4.0-0.10b8.fc15.
Comment 7 Berrehouc Nicolas 2011-01-06 05:49:06 EST
Update to firefox-4.0-0.10b8.fc15.i686.rpm from koji works fine.
Comment 8 dominique 2011-01-06 13:14:43 EST
For me update to firefox-4.0-0.10b8.fc15.x86-64.rpm from koji work fine.
Bug is closed.
Comment 9 Christopher Aillon 2011-01-07 14:11:53 EST
*** Bug 668029 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.