Bug 66765 - Modem connection failed
Modem connection failed
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-15 17:27 EDT by Nikos Charonitakis
Modified: 2014-03-16 22:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:01:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikos Charonitakis 2002-06-15 17:27:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; el-gr; rv:0.9.9) Gecko/20020513

Description of problem:
Problems setting a connection via modem

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Make a connection with modem to an isp
2.then delete the connection and device from config network
3.make a new connection via modem to an isp
	

Actual Results:  when i try to connent with the new connection config network things
that i use the old one and fails to connect 

Expected Results:  connect

Additional info:

the problem solved when i mannualy deleted the file /etc/ppp/peers/ppp0
-when i look in to that file i saw that contains the name of my old deleted
connection (lets say that was named  A) and my actual connection (named B)was
not there.
So i deleted again my new connection then deleted ppp0 and i make an even newer 
connection that fiinally worked...
Comment 1 Nikos Charonitakis 2002-06-20 09:18:58 EDT
also i noticed that although i deleted all the modem devices from graphic-ui and
try to make a new device and connection, the file
/etc/sysconfig/network-scripts/ifcfg-ppp0 keeps the old modem i gave by mistake
(/dev/ttyACM0) instead the right one i gave in the new connection
(/dev/input/ttyACM0)
so nothing worked until i edited by hand the ifcfg-ppp0 and replace the modem
selection with the proper one.
Comment 2 Nikos Charonitakis 2002-06-20 09:22:25 EDT
the second comment is about my second usb modem
Comment 3 Harald Hoyer 2002-06-26 06:34:10 EDT
This seems to be broken... Can we really only have one WVDIALSECT per DEVNAME???

$ rpm -qf /etc/sysconfig/network-scripts/ifup-ppp
initscripts-6.67-1

....
PEERCONF=/etc/ppp/peers/${DEVNAME}

if [ "${DEBUG}" = "yes" ]; then
  CHATDBG="-v"
fi

if [ ! -f ${PEERCONF} ]; then
  if [ -z "${WVDIALSECT}" ] ; then
  ....
  fi
  logger -s -p daemon.notice -t ifup-ppp \
    $"Setting up a new ${PEERCONF} config file"
  if [ -f /etc/ppp/peers/${DEVICE} ]; then
    cp -f /etc/ppp/peers/${DEVICE} ${PEERCONF}
  else
    touch ${PEERCONF}
  fi
  if [ "${WVDIALSECT}" ]; then
    echo "connect \"/usr/bin/wvdial --remotename ${DEVNAME} --chat '${WVDIALSECT}'\
"" >> ${PEERCONF}
  else
    echo "connect \"/usr/sbin/chat ${CHATDBG} -f ${CHATSCRIPT}\"" >> ${PEERCONF}
  fi
fi
...
Comment 4 Nikos Charonitakis 2003-09-20 13:14:49 EDT
similar problems are true for rh9 and severn.
see "steps to reproduce" section
here some output

iso-8859-1Sep 20 20:01:43 xerolia ΣεÏ\200 20 20:01:43 ifup-ppp: pppd started
for ppp1 on /dev/input/ttyACM0 at 115200
Sep 20 20:01:43 xerolia pppd[6037]: pppd 2.4.1 started by root, uid 0
Sep 20 20:01:44 xerolia wvdial[6052]: WvDial: Internet dialer version 1.53 
Sep 20 20:01:44 xerolia wvdial[6052]: Warning: section [Dialer Forthnet64K] does
not exist in wvdial.conf. 
Sep 20 20:01:44 xerolia wvdial[6052]: Initializing modem. 
Sep 20 20:01:44 xerolia wvdial[6052]: Sending: ATZ 
Sep 20 20:01:44 xerolia wvdial[6052]: ATZ 
Sep 20 20:01:44 xerolia wvdial[6052]: OK 
Sep 20 20:01:44 xerolia wvdial[6052]: Modem initialized. 
Sep 20 20:01:44 xerolia wvdial[6052]: Configuration does not specify a valid
phone number. 
Sep 20 20:01:44 xerolia wvdial[6052]: Configuration does not specify a valid
login name. 
Sep 20 20:01:44 xerolia wvdial[6052]: Configuration does not specify a valid
password. 
Sep 20 20:01:44 xerolia pppd[6037]: Connect script failed


Comment: [Dialer Forthnet64K] should be [Dialer isdn64K]
my conection Forthnet64K is deleted and then replaced by isdn64K
Comment 5 Bill Nottingham 2005-09-29 16:01:29 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.