This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 66823 - installer aborts with Cirrus Logic GD 543x - trap ddc probe segfault in kudzu
installer aborts with Cirrus Logic GD 543x - trap ddc probe segfault in kudzu
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-06-17 09:47 EDT by Michael Redinger
Modified: 2014-03-16 22:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-05 20:13:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X config file (2.27 KB, text/plain)
2002-06-20 04:15 EDT, Michael Redinger
no flags Details
X log file (21.86 KB, text/plain)
2002-06-20 04:16 EDT, Michael Redinger
no flags Details
X log for VertRefresh 60 (21.90 KB, text/plain)
2002-06-20 05:09 EDT, Michael Redinger
no flags Details
debugging kudzu (475.98 KB, application/octet-stream)
2002-06-28 11:06 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Michael Redinger 2002-06-17 09:47:54 EDT
The installer aborts when using Cirrus Logic GD 543x video chips.

After promting "Running anaconda - please wait ..." the installer
aborts with no specific error (I checked all consoles). It only
says:
"install exited abnormally -- received signal 11"

As at this point the installer normally probes for the video chip, I
think this could be the problem (but why does it happen with TUI installs?).
Even more, both computers have an onboard Cirrus Logic GD 543x chip:
- Cirrus Logic GD 5434-7 [Alpine] (rev 252)
- Cirrus Logic GD 5436 [Alpine] (rev 0)

I replaced the chip with a Matrox Millenium and everything worked fine then.

Both worked fine in 7.2 and 7.3.

What's especially annoying is that even a "text" install does not work.
Therefore setting the priority and severity to high (hey, we have maybe 300 or
400 of those computers running Red Hat Linux ...).

Comment from Mike Harris on the beta list:

> Hmm, the Alpine chips should work.  Nothing has really changed
> since 7.3 that would break them AFAIR.  I've got a 5446 here that
> still works, but don't have the 543x's handy.
Comment 1 Michael Fulbright 2002-06-17 12:13:25 EDT
Mike H., any ideas?
Comment 2 Michael Redinger 2002-06-17 16:31:30 EDT
One thing I noticed right now:
We always used XF 3 for these cards in 7.x. AFAIR I did never get them work
using XF 4. Just in case this helps ...
Comment 3 Michael Redinger 2002-06-17 17:00:36 EDT
> I've seen a report like this as well, but have not been able to locate this
> hardware locally.
>
> Have you tried the 'skipddc' option on the boot command line?


Completely right. Adding skipddc works fine.
The monitor supports DDC, this works fine (not too difficult to guess as the
Matrox Millenium works fine) but the card doesn't.
*Me still thinks this is a bug.*

Comment 4 Michael Fulbright 2002-06-17 17:50:17 EDT
I'll try to find one of these cards and trap the segfault better.  Do you have a
particular brand of this card?
Comment 5 Michael Fulbright 2002-06-17 17:53:47 EDT
Hmm this is a REALLY OLD chipset :)  I found this on ebay:

http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=2032348025

I'm not sure I'm going to be able to find a machine to test with...
Comment 6 Michael Fulbright 2002-06-17 17:57:45 EDT
Bill do you think we could trap the segfault that occurs in the magic ddc probe
call?
Comment 7 Mike A. Harris 2002-06-17 18:09:21 EDT
There are some 2D acceleration bugs with this hardware also, however nobody
has really used 4.x when 3.3.6 was around, so the problems have basically
never gotten fixed.  There is an issue aparently with 8x8 fills.  This
doesn't sound like the problem in this report however.  I thought I'd
mention it nonetheless, since it is rare to get reports about this hardware.

I have got the chip specs for almost all cirrus hardware I believe, but
not sure if I've got a 543x handy or not for testing.

Can you possibly do an install, bypass X configuration, then once installed,
configure X, and attach the X server log and config?  The log might
provide clues as to what is failing.
Comment 8 Bill Nottingham 2002-06-17 18:10:27 EDT
Um, if you run it under a debugger, probably.

Once you install, does kudzu -p -b ddc segfault?
Comment 9 Mike A. Harris 2002-06-17 18:11:51 EDT
Just dug through a box and found a 5446 and a 5436.  Don't know if either
card works or not but I'll try them out.
Comment 10 Michael Redinger 2002-06-19 07:04:05 EDT
Yes, kudzu -p -b ddc segfaults.
Comment 11 Michael Redinger 2002-06-20 04:15:01 EDT
I now installed and ran Xconfigurator manually. Attaching the config file and log.

Basically Xconfigurator ran fine, didn't crash. However, I configured 800x600
(16bit), but X starts with 640x480 (even the test screen started by Xconfigurator).

Comment 12 Michael Redinger 2002-06-20 04:15:34 EDT
Created attachment 61767 [details]
X config file
Comment 13 Michael Redinger 2002-06-20 04:16:17 EDT
Created attachment 61768 [details]
X log file
Comment 14 Alan Hourihane 2002-06-20 04:45:34 EDT
In your XF86Config file, change your VertRefresh line to this

  VertRefresh 60

Comment 15 Michael Redinger 2002-06-20 04:51:05 EDT
Doesn't help, same result.
Comment 16 Alan Hourihane 2002-06-20 04:57:19 EDT
Can you post another log from /var/log/XFree86.0.log with that set ?
Comment 17 Michael Redinger 2002-06-20 05:09:25 EDT
Created attachment 61769 [details]
X log for VertRefresh 60
Comment 18 Michael Fulbright 2002-06-20 23:04:29 EDT
I've wrapped the ddcprobe calls we make to kudzu so if it segfaults it won't
bring anaconda/rhpl down.
Comment 19 Bill Nottingham 2002-06-24 10:49:14 EDT
If you run kudzu -p -b ddc under gdb, where does it segfault?
Comment 20 Michael Redinger 2002-06-28 07:19:11 EDT
# gdb kudzu
(gdb) run -p -b ddc
Starting program: /usr/sbin/kudzu -p -b ddc
(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x0805ccd4 in ddcProbe ()
(gdb) bt
#0  0x0805ccd4 in ddcProbe ()
#1  0x08051f53 in probeDevices ()
#2  0x0804fec0 in main ()
#3  0x400ae25a in __libc_start_main () from /lib/libc.so.6
Comment 21 Bill Nottingham 2002-06-28 11:06:13 EDT
Created attachment 63046 [details]
debugging kudzu
Comment 22 Bill Nottingham 2002-06-28 11:07:14 EDT
Can you try gdb on the debugging kudzu?
Comment 23 Michael Redinger 2002-06-28 15:53:46 EDT
(I updated to slang-1.4.5-7 from rawhide (--nodeps) to make this binary work.)

# gdb ./kudzu
(gdb) run -p -b ddc
Starting program: /root/kudzu -p -b ddc

Program received signal SIGSEGV, Segmentation fault.
0x0805a830 in ddcProbe (probeClass=CLASS_UNSPEC, probeFlags=1, devlist=0x0)
    at ddc.c:258
258     ddc.c: No such file or directory.
        in ddc.c
(gdb) bt
#0  0x0805a830 in ddcProbe (probeClass=CLASS_UNSPEC, probeFlags=1, devlist=0x0)
    at ddc.c:258
#1  0x08050b12 in probeDevices (probeClass=CLASS_UNSPEC, probeBus=BUS_DDC,
    probeFlags=1) at kudzu.c:584
#2  0x0804ee5c in main (argc=4, argv=0xbffffb84) at hwconf.c:1932
#3  0x400ae25a in __libc_start_main () from /lib/libc.so.6
Comment 24 Michael Fulbright 2002-08-01 00:15:08 EDT
Reassigning, as anaconda will not fall over because of this anymore.
Comment 25 Bill Nottingham 2003-02-05 20:13:34 EST
We put a fix in current kudzu for segfaulting on bad ddc info... please reopen
if this persists in Phoebe or later.

Note You need to log in before you can comment on or make changes to this bug.