Bug 669092 - [Errata testing] Probing everything in vfs fails on i386 after rebase
[Errata testing] Probing everything in vfs fails on i386 after rebase
Status: CLOSED DUPLICATE of bug 669085
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: systemtap (Show other bugs)
4.9
i386 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Frank Ch. Eigler
qe-baseos-tools
: Rebase, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-12 11:37 EST by Petr Muller
Modified: 2016-09-19 22:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 14:47:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Muller 2011-01-12 11:37:05 EST
Description of problem:
# rm -rf /root/.systemtap/cache/*; stap -v -p4 -e 'probe vfs.*, vfs.*.*,generic.*.*,generic.*.*.* {}'
Pass 1: parsed user script and 72 library script(s) using 19248virt/12100res/2016shr kb, in 360usr/20sys/382real ms.
(SNIPPED WARNINGS)
semantic error: unable to find local 'filp' near pc 0xc015d441 in <unknown>(fs/read_write.c) (alternatives: $ti): identifier '$filp' at /usr/share/systemtap/tapset/vfs.stp:528:19
        source:         dev = __file_dev($filp)
                                         ^
semantic error: unable to find local 'filp' near pc 0xc015d441 in <unknown>(fs/read_write.c) (alternatives: $ti): identifier '$filp' at :529:45
        source:         devname = __find_bdevname(dev, __file_bdev($filp))
                                                                   ^
semantic error: unable to find local 'filp' near pc 0xc015d5ed in <unknown>(fs/read_write.c) (alternatives: $ti): identifier '$filp' at :563:19
        source:         dev = __file_dev($filp)
                                         ^
semantic error: unable to find local 'filp' near pc 0xc015d5ed in <unknown>(fs/read_write.c) (alternatives: $ti): identifier '$filp' at :564:45
        source:         devname = __find_bdevname(dev, __file_bdev($filp))
                                                                   ^
semantic error: unable to find local 'file' near pc 0xc015d044 in down(fs/read_write.c) (alternatives: $sem): identifier '$file' at :145:19
        source:         dev = __file_dev($file)
                                         ^
semantic error: unable to find local 'file' near pc 0xc015d044 in down(fs/read_write.c) (alternatives: $sem): identifier '$file' at :146:45
        source:         devname = __find_bdevname(dev, __file_bdev($file))
                                                                   ^
semantic error: unable to find local 'filp' near pc 0xc01443f1 in <unknown>(mm/filemap.c) (alternatives: $ti): identifier '$filp' at :241:19
        source:         dev = __file_dev($filp)
                                         ^
semantic error: unable to find local 'filp' near pc 0xc01443f1 in <unknown>(mm/filemap.c) (alternatives: $ti): identifier '$filp' at :242:45
        source:         devname = __find_bdevname(dev, __file_bdev($filp))
                                                                   ^
semantic error: unable to find local 'file' near pc 0xc014448c in down(mm/filemap.c) (alternatives: $sem): identifier '$file' at :274:19
        source:         dev = __file_dev($file)
                                         ^
semantic error: unable to find local 'file' near pc 0xc014448c in down(mm/filemap.c) (alternatives: $sem): identifier '$file' at :275:45
        source:         devname = __find_bdevname(dev, __file_bdev($file))
                                                                   ^
Pass 2: analyzed script: 56 probe(s), 91 function(s), 6 embed(s), 57 global(s) using 79940virt/38232res/3700shr kb, in 2230usr/900sys/3210real ms.
Pass 2: analysis failed.  Try again with another '--vp 01' option.

Version-Release number of selected component (if applicable):
systemtap-1.3-3.el4.i386
2.6.9-89.33.1.ELsmp

How reproducible:
always

Steps to Reproduce:
1. stap -v -p4 -e 'probe vfs.*, vfs.*.*,generic.*.*,generic.*.*.* {}'
2.
3.
  
Actual results:
fail in phase 2

Expected results:
no fail

Additional info:
Comment 2 Frank Ch. Eigler 2011-01-12 12:17:12 EST
Same class of issues as bug #669085.
Comment 3 Frank Ch. Eigler 2011-01-13 14:47:31 EST

*** This bug has been marked as a duplicate of bug 669085 ***

Note You need to log in before you can comment on or make changes to this bug.