Bug 669810 - yum downgrade gets confused by several versions of dependencies
yum downgrade gets confused by several versions of dependencies
Status: CLOSED DUPLICATE of bug 549404
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-14 15:49 EST by Horst H. von Brand
Modified: 2014-01-21 18:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-20 15:28:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2011-01-14 15:49:46 EST
Description of problem:
I tried to downgrade cups, which depends on cups-libs. There are around 4 versions of cups (and cups-libs) available, and the downgrade fails. If I downgrade cups and cups-libs, the command goes through (but then yum hangs, and something hogs the CPU and the disk forever)

Version-Release number of selected component (if applicable):
yum-3.2.29-2.fc15.noarch

How reproducible:
No idea.

Steps to Reproduce:
1. yum downgrade cups
2.
3.
  
Actual results:
Complaints that there are several versions of cups-libs, error.

Expected results:
Downgrade

Additional info:
Comment 1 James Antill 2011-01-20 15:28:10 EST
this is kind of a long term thing...

*** This bug has been marked as a duplicate of bug 549404 ***

Note You need to log in before you can comment on or make changes to this bug.