Bug 670004 - [abrt] kdeutils-printer-applet-6:4.5.95-1.fc15: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
[abrt] kdeutils-printer-applet-6:4.5.95-1.fc15: Process /usr/bin/python was k...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
rawhide
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:52f7bf6143d34d22445b87a6c8c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-16 11:37 EST by Martin Kho
Modified: 2013-01-14 14:06 EST (History)
9 users (show)

See Also:
Fixed In Version: PyKDE4-4.5.95-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 14:06:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (32.85 KB, text/plain)
2011-01-16 11:37 EST, Martin Kho
no flags Details

  None (edit)
Description Martin Kho 2011-01-16 11:37:30 EST
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: python /usr/bin/printer-applet
comment: The "little typo" in PyQt4 is corrected :-)
component: kdeutils
executable: /usr/bin/python
kernel: 2.6.37-2.fc15.x86_64
package: kdeutils-printer-applet-6:4.5.95-1.fc15
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1295195422
uid: 500

How to reproduce
-----
1. Be sure PyQt4 (4.8.3-0.1.454d07a16153 and sip (4.12.1-0.1.fa100876a783) are latest updates
2. run at the command promt "printer-applet"
3.
Comment 1 Martin Kho 2011-01-16 11:37:34 EST
Created attachment 473722 [details]
File: backtrace
Comment 2 Kevin Kofler 2011-01-16 11:43:16 EST
Looks like the new snapshots are binary-incompatible and PyKDE4 needs a rebuild.

(Rex, why did you upgrade to snapshots? Just backporting the fix for the typo would have been a lot safer, I think.)
Comment 3 Martin Kho 2011-01-16 12:26:26 EST
Hi,

Rawhide is still pre-alpha, so it's no problem :-)

Martin Kho
Comment 4 Rex Dieter 2011-01-16 16:34:22 EST
Upstream labeled this snapshot an RC for the next release.  anyway, is it worth trying to track down the incompat, or should we just rebuild kdebindings? (I'm leaning toward the latter atm).
Comment 5 Rex Dieter 2011-01-16 16:36:29 EST
Try giving PyKDE4-4.5.95-2 a whirl,
http://koji.fedoraproject.org/koji/taskinfo?taskID=2724711
Comment 6 Martin Kho 2011-01-16 16:54:18 EST
Hi,

I did a rebuild of kdebindings on my rawhide. It solved the crash. I'll try your rebuild.

Martin Kho
Comment 7 Martin Kho 2011-01-17 08:46:37 EST
Hi,

Okay, updated PyKDE4 and everything is fine again. Please close this report.

Thanks,

Martin Kho
Comment 8 A S Alam 2011-01-17 12:43:26 EST
Package: kdeutils-printer-applet-6:4.5.95-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. everytime login to KDE session, it crashed
2.
3.
Comment 9 Martin Kho 2013-01-14 12:45:26 EST
Huh, this report is still open. The issue was fixed (comment #5) wasn't it?

Thanks,

Martin Kho
Comment 10 Kevin Kofler 2013-01-14 14:06:48 EST
Yes, it was, eons ago (comment #8 probably just didn't have the fix yet, no reports newer than 2011-01-17).

Note You need to log in before you can comment on or make changes to this bug.