Bug 670142 - segfaults when browsing youtube
Summary: segfaults when browsing youtube
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: webkitgtk
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-17 10:27 UTC by Tomas Pelka
Modified: 2011-01-24 09:38 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-01-24 09:38:11 UTC


Attachments (Terms of Use)
webkitLauncher-s390x backtrace (13.01 KB, application/octet-stream)
2011-01-17 10:27 UTC, Tomas Pelka
no flags Details

Description Tomas Pelka 2011-01-17 10:27:42 UTC
Created attachment 473806 [details]
webkitLauncher-s390x backtrace

Description of problem:
When browsing http://www.youtube.com via GtkLauncher or gimp browser-plugin I always get an segfault:

Program received signal SIGSEGV, Segmentation fault. JSC::Interpreter::privateExecute (this=0x20007fe4a00, flag=<value optimized out>, registerFile=0x20007fe4a18, callFrame=0x2000a252a90, exception=0x3ffffa46868) at JavaScriptCore/interpreter/Interpreter.cpp:3478 3478 argStore[i] = callFrame->registers()[i - RegisterFile::CallFrameHeaderSize - expectedParams - argCount - 1]; 

Spotted on s390x and ppc64


Version-Release number of selected component (if applicable):
webkitgtk-1.2.6-1.el6_0

How reproducible:
100%

Steps to Reproduce:
via GtkLauncher
1. run /usr/libexec/webkitgtk/GtkLauncher http://www.youtube.com
2.
3.
via GIMP browser-plugin
1. Run gimp
2. Help->Plug-in Browser
3. hit Help button
4. hit "Visit the GIMP documentation website" on top right
5. search for youtube -- you should get the google website
5. hit the Google Home link on bottom
6. search for youtube 
7. click on the first result and open it 
  
Actual results:
segfault

Expected results:
no segfault

Additional info:
Is is an regression, old version of webkitgtk worked just fine.

Comment 2 RHEL Product and Program Management 2011-01-17 10:58:23 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Tomas Pelka 2011-01-17 13:22:09 UTC
Sefault appeared also on x86_64.

Comment 4 Huzaifa S. Sidhpurwala 2011-01-24 09:37:04 UTC
This is fixed by the following commits upstream

commit 34df60de3d8e524662995beb9243033c24a61797
Author: Huzaifa Sidhpurwala <huzaifas@redhat.com>
Date:   Wed Jan 19 14:16:05 2011 +0530

    Complete the backport and fix regression caused by:
    f236c158708a2116a799174bd2722fd721e663c4


This issue probably affects fedora builds as well.


Note You need to log in before you can comment on or make changes to this bug.