Bug 670749 - When an EAR is removed, an option should be exposed to remove all of its deployed resources or the removal of its deployed resources should be forced
When an EAR is removed, an option should be exposed to remove all of its depl...
Status: CLOSED DUPLICATE of bug 536247
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.0
All Unspecified
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-19 04:04 EST by bkramer
Modified: 2011-02-08 11:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-08 11:02:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The EAR file used for testing. (4.59 MB, application/octet-stream)
2011-01-19 04:04 EST, bkramer
no flags Details

  None (edit)
Description bkramer 2011-01-19 04:04:51 EST
Created attachment 474226 [details]
The EAR file used for testing.

Description of problem:

EAR deployed in JON 2.4 can be removed without problem as there is "delete check box" that can be selected and there is the "DELETE" button exposed on the resources page. However, there is no option to remove all of EARs deployed resources at the moment.


Version-Release number of selected component (if applicable):
Tested in JON 2.4.0 

How reproducible:
Reproducible every time.

Steps to Reproduce:
I used customers EAR file that deploys the number of Session Beans with it. 

1. Run JON server;
2. Run JON agent;
3. Run JBoss - I used 4.3, "all" configuration;
4. Add JBoss to the inventory;
5. Deploy BitacoraEar-3.4.ear file (for JBoss 4.3 resource -> go to Inventory -> Overview tab and add EAR file)
6. Confirm that the EAR file is properly deployed and that there are several Stateless Session Beans deployed.
7. To delete the EAR file and all resources that were deployed with it - on the same Inventory -> Overview tab -> check the delete check box located next to the BitacoraEar-3.4.ear file and press "DELETE" button. (please note that there is no "delete check box" for Session Beans that were added when EAR was deployed)
  
Actual results:

Only BitacoraEar-3.4.ear file will be deleted while all Stateless Session Beans that were deployed with deployment of the EAR file are still there and they can't be removed (only their availability is changed to unavailable).

Expected results:

When an EAR is removed in JON, an option should be exposed to remove all of its deployed resources or the removal of its deployed resources should be forced. 


Additional info:
Comment 1 bkramer 2011-01-19 05:48:40 EST
After this was submitted, I found [1] which exactly address the problem above. 

[1] https://bugzilla.redhat.com/show_bug.cgi?id=536247
Comment 2 Larry O'Leary 2011-02-08 11:02:52 EST

*** This bug has been marked as a duplicate of bug 536247 ***

Note You need to log in before you can comment on or make changes to this bug.