Bug 67076 - The default configuration file should include a WinMM section
The default configuration file should include a WinMM section
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: wine (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-19 14:51 EDT by Göran Uddeborg
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-15 08:24:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2002-06-19 14:51:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020528

Description of problem:
Running wine on any program gives a warning about missing WinMM section in the
configuration file.  This is with the default /etc/wine.reg coming with the
package.  It seems it would make sense to add such a section to the default file.

Version-Release number of selected component (if applicable):20020327-2


How reproducible:
Always

Steps to Reproduce:
1.Run "wine prog.exe" for any windows program prog.exe.

Actual Results:  These error messages are issued:

err:mmsys:MMDRV_InitHardcoded You didn't setup properly the config file for the
Wine multimedia modules.
Will use the hard-coded setup, but this will disappear soon.
Please add a WinMM section to your Wine config file.

(The program still runs though, this is not a fatal error.)
Comment 1 Karsten Hopp 2002-07-11 07:43:53 EDT
The is a reference to winmm in the config files of the latest wine package. I hope that it fixes 
this, but I cannot test this as I have absolutely no Windows program to test it. Please test it 
with wine-20020605-1 (soon in rawhide) and reopen this report if the problem still exists.
Comment 2 Göran Uddeborg 2002-07-12 15:22:28 EDT
I can't find any WinMM *section* in wine-20020605-1 wine.reg.  Maybe you refer
to the reference to winmm in the DllOverrides section?

But what is missing is an WinMM section as described in section 4.1.2.10 of the
Wine configuration documentation.,
(http://www.winehq.org/Docs/wine-user/configuring.shtml#AEN875)

I found a sample configuration file with this content:

[WinMM]
"Drivers" = "wineoss.drv"
#"Drivers" = "winearts.drv"
"WaveMapper" = "msacm.drv"
"MidiMapper" = "midimap.drv"

I added that to my wine.reg, and that helped removing to complaint from wine. 
Otherwise Wine seems to work to the same extent it did before; things didn't get
neither worse nor better.
Comment 3 Göran Uddeborg 2003-09-15 08:24:45 EDT
Since wine is no longer part of the distribution, I guess this bug isn't
relevant any more.

Note You need to log in before you can comment on or make changes to this bug.