Bug 67085 - gftp mangles ftp proxy dialog
gftp mangles ftp proxy dialog
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gftp (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-06-19 15:52 EDT by Tim Clymo
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-19 09:50:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2002-06-19 15:52:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
There seems to be some problem with the way gftp options generates the dialog it
hands off to an ftp proxy

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Fire up gftp - no $HOME/.gftp dir, so this is a clean config
2.Select "FTP -> Options" from menu bar, followed by "FTP" tab
3.Enter (for example) "localhost" as Proxy Hostname, 3121 as Proxy port, and
"user@host NOAUTH" as Proxy server type
4.Proposed proxy dialog appears in window as "USER %hu@%hh" followed by "PASS %hp"
5.Click "OK" to save, and then return to step 2.
	

Actual Results:  Proposed dialog now reads "Custom" type instead of "user@host
NOAUTH",
and is the following:
USER %hu@%hh
PASS %hp
USER %hu@%hh
PASS %hp

NB the original (correct) proxy dialog seems to have been duplicated

Expected Results:  Dialog should have been as originally proposed and saved,
type should not be "Custom" but should be as originally selected ("user@host
NOAUTH" in this example)

Additional info:

If, having done this, you shut down gftp, manually edit $HOME/.gftp/gftprc and
change the proxy_config variable on line 102 to what it "should" be (ie "USER
%hu@%hh%nPASS %hp%n" in this case) then, on starting up gftp again and looking
at the FTP Options everything looks OK and it works as originally expected.

I also don't think this is a gftp problem as such because I installed Valhalla's
gftp-2.0.11-2 on an Enigma box and it seemed to work OK. I have no idea of the
root cause here, although maybe it could be something to do with gtk+ (the only
package upon which gftp appears to depend according to RPM)
Comment 1 Havoc Pennington 2002-07-11 16:00:02 EDT
Note sent upstream about this.
Comment 2 Havoc Pennington 2002-07-11 18:22:07 EDT
Reply from Brian Masney:

 I just checked this, and this bug isn't present in my current version of 
gftp. I do have a newer version of gftp online at
http://www.gftp.org/gftp-2.0.13-beta.tar.bz2 that I'd like to get into the 
next redhat release. I'm going to finish going through all my email in the
next week and make sure there is no outstanding bugs to fix, then make a final 
release of gftp. One thing to note on this release I took out several options 
and took out the legacy SSH protocol. It's all documented in the changelog.
Comment 3 Karsten Hopp 2002-08-14 08:19:14 EDT
I've tested this with the latest rawhide package. gftp still writes a lot of 
garbage into gftprc: 
 
proxy_config=USER %hu@%hh%nPASS %hp%nUSER %hu@%hh%nPASS 
%hp%n@^K1@0<d6>^T^H<a0>e^QBx<e9><ff><bf><e1><dd>^FB(<9b>%n^H<a0>e^QBkp0@@^K1@(<9b>%n^H<a0>e^QB<98><e9><ff><bf>^L@0@<b0>e^QB<80>S^QB<b8><e9><ff><bf><b6><e8>^FB<a0>e^QB(<9b>%n^H<c8><e9><ff><bf><d0>$^^@X<ca>^T^H^A
Comment 4 Tim Waugh 2002-08-19 09:50:24 EDT
I can't reproduce this with gftp-2.0.13-4.  Seems to be fixed now?
Comment 5 Tim Clymo 2002-08-20 17:23:36 EDT
Yes - seems to be fixed in 2.0.13-4

Note You need to log in before you can comment on or make changes to this bug.