Bug 670882 - [abrt] gnash-1:0.8.8-4.fc14: extent_tree_ad_s_RB_REMOVE: Process /usr/bin/gtk-gnash was killed by signal 11 (SI)
Summary: [abrt] gnash-1:0.8.8-4.fc14: extent_tree_ad_s_RB_REMOVE: Process /usr/bin/gtk...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnash
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Hicham HAOUARI
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:94973b8c4c08f4df3e5f7da0221...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-19 15:35 UTC by William A. Mahaffey III
Modified: 2011-03-27 19:35 UTC (History)
4 users (show)

Fixed In Version: gnash-0.8.9-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-18 03:59:51 UTC


Attachments (Terms of Use)
File: backtrace (42.70 KB, text/plain)
2011-01-19 15:35 UTC, William A. Mahaffey III
no flags Details

Description William A. Mahaffey III 2011-01-19 15:35:08 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/gtk-gnash -u http://us.js2.yimg.com/us.js.yimg.com/lib/fi/201008171841/us/swf/yfcv3/flashchart.swf -U http://finance.yahoo.com/echarts?s=DHT+Interactive#symbol=DHT;range=5d -x 140509248 -j 780 -k 380 -F 15:16 -P allowscriptaccess=always -P bgcolor=#ffffff -P flashvars=lcId=1295451364097&localeUri=http%3A//us.js2.yimg.com/us.js.yimg.com/lib/fi/201008171841/us/locale/yfcv3/dictionary.xml&chartHost=chartapi.finance.yahoo.com&keyeventsHost=finance.yahoo.com&sigdevsHost=ads.finance.yahoo.com&buildType=prod&state=symbol%3Ddht%3Brange%3D5d%3Bindicator%3Dvolume%3Bcharttype%3Dline%3Bcrosshair%3Don%3Bohlcvalues%3D0%3Blogscale%3Don&source=undefined -P height=380px -P loop=false -P menu=false -P name=test -P pluginspage=http://www.macromedia.com/go/getflashplayer -P src=http://us.js2.yimg.com/us.js.yimg.com/lib/fi/201008171841/us/swf/yfcv3/flashchart.swf -P type=application/x-shockwave-flash -P width=100% -P wmode=opaque -
comment: See above ....
component: gnash
crash_function: extent_tree_ad_s_RB_REMOVE
executable: /usr/bin/gtk-gnash
kernel: 2.6.35.10-74.fc14.x86_64
package: gnash-1:0.8.8-4.fc14
rating: 4
reason: Process /usr/bin/gtk-gnash was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1295451388
uid: 1110

How to reproduce
-----
1.visited finance.yahoo.com
2.tried to generate a plot on that site, not sure about more details :-/ ....
3.

Comment 1 William A. Mahaffey III 2011-01-19 15:35:12 UTC
Created attachment 474298 [details]
File: backtrace

Comment 2 Fedora Admin XMLRPC Client 2011-01-29 22:03:44 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Fedora Admin XMLRPC Client 2011-01-29 22:04:46 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Hicham HAOUARI 2011-02-19 01:59:34 UTC
Is this crash reproducible ?

Comment 5 William A. Mahaffey III 2011-02-19 04:19:33 UTC
I am not entirely sure :-/ .... Can you duplicate from the crash-report info ? Try this URL: http://finance.yahoo.com/q?s=ISH,TNP,DHT,^GSPC&d=s, then click on 1 of the links below 1 of the plots, to look at a plot for a period other than 1 day, that's where this came from.


I had a flurry of these (gnash crashes), all submitted by the abrt daemon, over a period of weeks. I mostly don't recall exactly what triggered them, I sorta hoped the automatically generated report would be detailed enough .... In all cases (IIRC) I was surfing & wound up looking at video, often YouTube or FoodTV, but not always .... I realize that ain't much help, but it's all I got .... I have had a few other sporadic crashes which got auto-reported, almost always classified as a new bug, when in fact I suspect they should have *all* been duplicates of an existing bug somewhere, maybe this one. I have yum-upgraded a couple of times since, maybe it got fixed ????

Comment 6 William A. Mahaffey III 2011-02-19 04:22:33 UTC
P.S. try clicking on the '5-day' link under the DHT daily plot, that is where the failure occured in this report & that's how I got there, click on the link in the last message to get 4 plots/quotes on the screen, then try to get the 5-day plot for stock symbol 'DHT' .... HTH ....

Comment 7 Hicham HAOUARI 2011-02-19 11:05:06 UTC
We are gonna disable jemalloc for next release since it seems to cause lot of memory allocation issues.

Comment 8 Fedora Update System 2011-03-13 16:53:31 UTC
gnash-0.8.9-0.1.20110312git.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnash-0.8.9-0.1.20110312git.fc14

Comment 9 Fedora Update System 2011-03-13 16:56:04 UTC
gnash-0.8.9-0.1.20110312git.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnash-0.8.9-0.1.20110312git.fc13

Comment 10 Fedora Update System 2011-03-13 16:58:33 UTC
gnash-0.8.9-0.1.20110312git.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnash-0.8.9-0.1.20110312git.fc15

Comment 11 Fedora Update System 2011-03-18 03:57:22 UTC
gnash-0.8.9-0.1.20110312git.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-03-19 02:15:17 UTC
gnash-0.8.9-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnash-0.8.9-1.fc14

Comment 13 Fedora Update System 2011-03-19 02:22:43 UTC
gnash-0.8.9-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnash-0.8.9-1.fc13

Comment 14 Fedora Update System 2011-03-27 19:24:58 UTC
gnash-0.8.9-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2011-03-27 19:32:28 UTC
gnash-0.8.9-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.