Bug 67110 - Zsh startup files forget to add ~/bin to $PATH
Summary: Zsh startup files forget to add ~/bin to $PATH
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zsh   
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-20 05:23 UTC by Dmitry Bolkhovityanov
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-20 05:23:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dmitry Bolkhovityanov 2002-06-20 05:23:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
The $HOME/bin component isn't added to the $PATH.

Version-Release number of selected component (if applicable):
4.0.4-5

How reproducible:
Always

Steps to Reproduce:
1. echo $PATH


Actual Results:  The $HOME/bin is absent there

Expected Results:  $HOME/bin should be present somewhere near the end of $PATH

Additional info:

In RHL releases <=7.1 the ~/bin was added by /etc/zshrc (the line was "($path
$HOME/bin)").  

Currently zsh's path setting is unified with bash's in /etc/profile, but bash
doesn't suffer from this error since every user has "PATH=$PATH:$HOME/bin" in
their ~/.bash_profile (see /etc/skel/.bash_profile).

I'd suggest adding to /etc/profile the line

"pathmunge $HOME/bin after"

right after

"pathmunge /usr/X11R6/bin after"

Comment 1 Trond Eivind Glomsrxd 2002-06-28 17:13:44 UTC
Added in 4.0.4-8


Note You need to log in before you can comment on or make changes to this bug.