Bug 67112 - OOPS on X Shutdown
OOPS on X Shutdown
Status: CLOSED DUPLICATE of bug 67978
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-06-20 03:07 EDT by Parag Warudkar
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-09 16:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Parag Warudkar 2002-06-20 03:07:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
When X is shutdown, Rawhide kernel-2.4.18-5.47 oopses. This is _always_
reproducible. OOPS report attached below.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Reboot 
2.Execute startx
3.Logout of X.

	

Actual Results:  Kernel OOPS

Expected Results:  Should not OOPS

Additional info:

/sbin/lsmod:
i810_audio             24704   1 (autoclean)
ac97_codec             13376   0 (autoclean) [i810_audio]
soundcore               6500   2 (autoclean) [i810_audio]
i810                   72696   1
agpgart                43328   7 (autoclean)
parport_pc             19044   1 (autoclean)
lp                      9056   0 (autoclean)
parport                37056   1 (autoclean) [parport_pc lp]
3c59x                  30728   1
ide-cd                 34752   0 (autoclean)
cdrom                  33152   0 (autoclean) [ide-cd]
usb-uhci               26020   0 (unused)
usbcore                76704   1 [usb-uhci]
ext3                   69472   2
jbd                    51192   2 [ext3]

OOPS :
Jun 20 12:12:58 darkstar kernel: Unable to handle kernel paging request at
virtual address 0100001b
Jun 20 12:12:58 darkstar kernel:  printing eip:
Jun 20 12:12:58 darkstar kernel: c012e3f1
Jun 20 12:12:58 darkstar kernel: *pde = 00000000
Jun 20 12:12:58 darkstar kernel: Oops: 0000
Jun 20 12:12:58 darkstar kernel: i810 agpgart parport_pc lp parport 3c59x ide-cd
cdrom usb-uhci usbcore ext3 jb
Jun 20 12:12:58 darkstar kernel: CPU:    0
Jun 20 12:12:58 darkstar kernel: EIP:    0010:[unlock_page+1/96]    Not tainted
Jun 20 12:12:58 darkstar kernel: EIP:    0010:[<c012e3f1>]    Not tainted
Jun 20 12:12:58 darkstar kernel: EFLAGS: 00013246
Jun 20 12:12:58 darkstar kernel:
Jun 20 12:12:58 darkstar kernel: EIP is at unlock_page [kernel] 0x1 (2.4.18-5.47)
Jun 20 12:12:58 darkstar kernel: eax: 01000000   ebx: c163eb10   ecx: c163eb10 
 edx: 00000000
Jun 20 12:12:58 darkstar kernel: esi: dc8c4000   edi: dece3000   ebp: de615ee8 
 esp: de615ed4
Jun 20 12:12:58 darkstar kernel: ds: 0018   es: 0018   ss: 0018
Jun 20 12:12:58 darkstar kernel: Process X (pid: 688, stackpage=de615000)
Jun 20 12:12:58 darkstar kernel: Stack: c163eb10 e09cbdcb c163eb10 de8bb504
de77f800 de615f08 e09cbe80 dece3000
Jun 20 12:12:58 darkstar kernel:        dc8c4000 de944174 dece3000 de615f1c
dea0f8e4 de615f64 e09cc3f0 dece3000
Jun 20 12:12:58 darkstar kernel:        bffff800 00000040 00000002 00000000
00000000 00000000 00000000 00000000
Jun 20 12:12:58 darkstar kernel: Call Trace:
[ext3:__insmod_ext3_S.bss_L1024+1593963/283586421] i810_free_page [i810] 0x4b
Jun 20 12:12:58 darkstar kernel: Call Trace: [<e09cbdcb>] i810_free_page [i810] 0x4b
Jun 20 12:12:58 darkstar kernel:
[ext3:__insmod_ext3_S.bss_L1024+1594144/283586240] i810_dma_cleanup [i810] 0xa0
Jun 20 12:12:58 darkstar kernel: [<e09cbe80>] i810_dma_cleanup [i810] 0xa0
Jun 20 12:12:58 darkstar kernel:
[ext3:__insmod_ext3_S.bss_L1024+1595536/283584848] i810_dma_init [i810] 0x60
Jun 20 12:12:58 darkstar kernel: [<e09cc3f0>] i810_dma_init [i810] 0x60
Jun 20 12:12:58 darkstar kernel:
[ext3:__insmod_ext3_S.bss_L1024+1575837/283604547] i810_ioctl [i810] 0xbd
Jun 20 12:12:58 darkstar kernel: [<e09c76fd>] i810_ioctl [i810] 0xbd
Jun 20 12:12:58 darkstar kernel: [sys_ioctl+171/560] sys_ioctl [kernel] 0xab
Jun 20 12:12:58 darkstar kernel: [<c014e26b>] sys_ioctl [kernel] 0xab
Jun 20 12:12:58 darkstar kernel: [system_call+51/56] system_call [kernel] 0x33
Jun 20 12:12:58 darkstar kernel: [<c01092d3>] system_call [kernel] 0x33
Jun 20 12:12:58 darkstar kernel:
Jun 20 12:12:58 darkstar kernel:
Jun 20 12:12:58 darkstar kernel: Code: 0f b6 50 1b 8b 1c 95 88 9e 3a c0 89 c2 69
d2 01 00 37 9e 8b

X Version 4.2.0
Comment 1 Need Real Name 2002-07-09 16:24:28 EDT
'Me too', sortof.
I found that changing the video memory to 4Mb using Xconfigurator either fixed
the problem, or at least made it far less reproducible.
Comment 2 Mike A. Harris 2002-07-10 08:57:25 EDT

*** This bug has been marked as a duplicate of 67978 ***

Note You need to log in before you can comment on or make changes to this bug.