Bug 67115 - xfs crashes when sent SIGUSR1
xfs crashes when sent SIGUSR1
Status: CLOSED DUPLICATE of bug 64683
Product: Red Hat Linux
Classification: Retired
Component: psmisc (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-20 05:39 EDT by Dmitry Bolkhovityanov
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-20 08:49:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xfs config file (1.24 KB, text/plain)
2002-06-20 05:43 EDT, Dmitry Bolkhovityanov
no flags Details

  None (edit)
Description Dmitry Bolkhovityanov 2002-06-20 05:39:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
According to docs, xfs should reread its config file on SIGUSR1 arrival. But
sometimes it crashes.  I've spent some time trying to catch the situation when
it happens, and finally found the Anaconda-generated /etc/X11/fs/config on a
just-installed system to give 100% hits (I'll attach the config).

Version-Release number of selected component (if applicable):
XFree86-xfs-4.2.0-8

How reproducible:
Sometimes

Steps to Reproduce:
1.in some window do "strace -p `cat /var/run/xfs.pid`"
2.in another window, do "killall -USR1 xfs"

Actual Results:  xfs dies, with strace printing 

--- SIGPWR (Power failure) ---
+++ killed by SIGPWR +++


Expected Results:  Xfs should reread its config file and do appropriate things.

Additional info:

Since that can be a code-related bug, here is the system info:

Asus P3B-F motherboard, PIII-800, 1G RAM.  HDD is IBM DDYS-36950 SCSI,
filesystem is ext3.

BTW, previously I tried to catch the bug on a local machine, and when finally
did it, I did all commands from another one over ssh -- maybe this matters.
Comment 1 Dmitry Bolkhovityanov 2002-06-20 05:43:16 EDT
Created attachment 61770 [details]
xfs config file
Comment 2 Dmitry Bolkhovityanov 2002-06-20 05:56:29 EDT
Hmmm...  Just tried to do "kill" instead of "killall" for purity, and...  It
seems to be a bug in "killall" -- that proggie really sends SIGPWR instead of
SIGUSR1...  That is clearly visible if killall is ran as "strace -o
/tmp/killall.log `which killall` -USR1 xfs".
Comment 3 Mike A. Harris 2002-06-20 08:49:07 EDT
Indeed, this is a bug in killall.  I'm reassigning to that package, however
I've been informed that Trond may have resolved this issue already, so I'm
cc'ing him as well.
Comment 4 Trond Eivind Glomsrxd 2002-06-20 10:12:09 EDT

*** This bug has been marked as a duplicate of 64683 ***

Note You need to log in before you can comment on or make changes to this bug.