Bug 67117 - xosview does not work
xosview does not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: xosview (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
: 76950 (view as bug list)
Depends On:
Blocks: 107565
  Show dependency treegraph
 
Reported: 2002-06-20 06:38 EDT by Gerald Teschl
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 21:11:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xosview.strace (11.47 KB, text/plain)
2003-04-08 18:51 EDT, Chris Kloiber
no flags Details

  None (edit)
Description Gerald Teschl 2002-06-20 06:38:05 EDT
Description of Problem:
xosview does not work. Looks like it gets stuck when reading /proc/stat

Version-Release number of selected component (if applicable):
1.7.3

How Reproducible:
Start xosview.
 
Actual Results:
Nothing

Expected Results:
An xosview window popping up

Additional Information:
Probably should be dropped from the distribution.
Comment 1 Ngo Than 2002-06-20 08:40:21 EDT
i assume you have installed kernel-smp-2.4.18-4. You have to install
xosview-1.8.0-3. It should work. You find xosview-1.8.0-3 in rawhide
Comment 2 Nils Philippsen 2002-08-28 11:25:36 EDT
This should be rebuilt for 7.x, AS as well as the rawhide package has some
unfulfillable dependencies:

error: failed dependencies:
	libgcc_s.so.1   is needed by xosview-1.8.0-8
	libgcc_s.so.1(GCC_3.0)   is needed by xosview-1.8.0-8
	libstdc++.so.5   is needed by xosview-1.8.0-8
	libstdc++.so.5(GLIBCPP_3.2)   is needed by xosview-1.8.0-8
Comment 3 Nils Philippsen 2002-08-28 11:41:46 EDT
I should have written "Advanced Server" instead of AS in the last comment. Doh.
Comment 4 Gerald Teschl 2003-02-21 06:03:24 EST
Works with xosview-1.8.0-11 for me. Closing bug.
Comment 5 Nils Philippsen 2003-02-21 07:08:40 EST
Reopening bug, because -- as far as I can see -- there is no package for 7.3 and
Advanced Server available which fixes that problem. The 1.8.0-11 package is not
an official erratum for these versions, is it?
Comment 6 Nils Philippsen 2003-02-21 07:09:51 EST
*** Bug 76950 has been marked as a duplicate of this bug. ***
Comment 7 Nils Philippsen 2003-02-21 07:12:11 EST
Changing product to Advanced Server (as this is probably where it matters more
because AS will be around for wuite some time). Please fix it for 7.3, too --
should work with the same src.rpm, I guess.
Comment 8 Chris Kloiber 2003-04-08 18:48:27 EDT
Report from a customer via web ticket indicates that xosview-1.7.3-5 gives a
"Segmentation Fault" after he updated to errata kernel 2.4.9-e.16smp. I could
not reproduce a "Segmentation Fault" on my test unit, but the only option of
xosview I could make work was 'xosview -v' (prints the version). I ran an strace
of xosview and captured the output, (attached, or will be soon).
Comment 9 Chris Kloiber 2003-04-08 18:51:06 EDT
Created attachment 91021 [details]
xosview.strace
Comment 10 Ngo Than 2003-06-10 17:44:02 EDT
it's fixed in xosview-1.7.3-6.72.1, which you can find it in
/mnt/redhat/beehive/comps/dist/2.1AS-errata-candidate/xosview/1.7.3-6.72.1/

Chris/Nils: could you please test it?
Comment 19 John Flanagan 2004-04-21 21:11:03 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-381.html

Note You need to log in before you can comment on or make changes to this bug.