This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 672047 - Yumex Fails - AttributeError: Values instance has no attribute 'repos'
Yumex Fails - AttributeError: Values instance has no attribute 'repos'
Status: CLOSED DUPLICATE of bug 676525
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-23 09:47 EST by Stephen
Modified: 2011-02-19 02:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-19 02:50:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stephen 2011-01-23 09:47:45 EST
Description of problem:

When attempting to run Yumex it fails with an AttributeError.

Traceback given is as follows:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1314, in dispatcher
    self.parse_command(args[0], args[1:])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 1242, in parse_command
    self.get_packages(args[0], args[1])
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 71, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 509, in get_packages
    ygh = self.doPackageLists(pkgnarrow=narrow, showdups=show_dupes)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2245, in doPackageLists
    for (n,a,e,v,r) in self.up.getUpdatesList():
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 878, in <lambda>
    up = property(fget=lambda self: self._getUpdates(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 702, in _getUpdates
    self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 859, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 645, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 260, in populateSack
    self.doSetup()
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 72, in doSetup
    self.ayum.plugins.run('prereposetup')
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 184, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 117, in prereposetup_hook
    enable_debuginfo_repos(yb, conduit)
  File "/usr/lib/yum-plugins/auto-update-debuginfo.py", line 42, in enable_debuginfo_repos
    for opt, repoexp in opts.repos:
AttributeError: Values instance has no attribute 'repos'


Version-Release number of selected component (if applicable):


How reproducible:

Everytime

Steps to Reproduce:
1. Rum Yumex
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Lauridsen 2011-02-19 02:50:36 EST

*** This bug has been marked as a duplicate of bug 676525 ***

Note You need to log in before you can comment on or make changes to this bug.