Bug 67211 - logrotate file incorrect
Summary: logrotate file incorrect
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: samba (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL: N/A
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-21 01:48 UTC by Bojan Smojver
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-25 13:09:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bojan Smojver 2002-06-21 01:48:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
/etc/logrotate.d/samba contains:

---------------------------------------------
/bin/kill -HUP `cat /var/run/smbd.pid /var/run/nmbd.pid 2> /dev/null` 2>
/dev/null || true
---------------------------------------------

and it should be:

---------------------------------------------
/bin/kill -HUP `cat /var/run/samba/smbd.pid /var/run/samba/nmbd.pid 2>
/dev/null` 2> /dev/null || true
---------------------------------------------

because pid files get stored in /var/run/samba, not /var/run.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Install Samba RPM's from Rawhide, version 2.2.4-5
	
Actual Results:  Logrotate misconfigured.

Expected Results:  Should be fine ;-)

Additional info:

Comment 1 Trond Eivind Glomsrxd 2002-06-25 15:22:47 UTC
Fixed in 2.2.5-1

Comment 2 Nils Philippsen 2003-07-25 13:10:02 UTC
wrong bug, oops


Note You need to log in before you can comment on or make changes to this bug.