Bug 67226 - XFree86 4.1.0-25 SEGVs (when using galeon)
XFree86 4.1.0-25 SEGVs (when using galeon)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 06:20 EDT by Nicholas Clark
Modified: 2007-03-26 23:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-15 08:52:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree 86 server log (52.38 KB, text/plain)
2002-06-21 06:21 EDT, Nicholas Clark
no flags Details
XFree 86 server log (55.53 KB, text/plain)
2002-06-21 06:22 EDT, Nicholas Clark
no flags Details
XFree 86 server log (129.26 KB, text/plain)
2002-06-21 06:22 EDT, Nicholas Clark
no flags Details
/var/log/messages from time of most recent server crash, as requested (19.63 KB, text/plain)
2002-06-27 10:46 EDT, Nicholas Clark
no flags Details

  None (edit)
Description Nicholas Clark 2002-06-21 06:20:42 EDT
Description of Problem:

The X server is crashing with a SEGV.
This has ocurred at least 4 times a fraction of a second after following a link
on the galeon web browser. It has only happened since I upgraded to galeon 1.2.5 
(1.2.5 rpms downloaded from their site, mozilla 1.0 from mozilla's site)

The most recent crash was after following the link on The Register's home page
to this page:
http://www.theregister.co.uk/content/6/25824.html
However, I can now look at that page in galeon without the X server crashing.

Version-Release number of selected component (if applicable):

XFree86 Version 4.1.0 (Red Hat Linux release: 4.1.0-25)

How Reproducible:

Intermittent - about once or twice a week on my normal usage. Here are my
captured logfiles:

-rw-r--r--    1 nick     nick        53640 Jun 13 15:28 XFree86.0.log
-rw-r--r--    1 nick     nick        56861 Jun 14 16:31 XFree86.0.log.again
-rw-r--r--    1 nick     nick       132366 Jun 21 10:37 XFree86.0.log.againagain

Steps to Reproduce:
"Surf the web with galeon 1.2.5" it seems :-(

Actual Results:

(X server SEGVs)

Expected Results:

X server should never SEGV

Additional Information:
	
3 logs attached. I don't think that they are very helpful at tracking this
problem down. I'm not sure if running the X server under gdb for a few days
until it does it again would be helful.
Comment 1 Nicholas Clark 2002-06-21 06:21:34 EDT
Created attachment 62004 [details]
XFree 86 server log
Comment 2 Nicholas Clark 2002-06-21 06:22:00 EDT
Created attachment 62005 [details]
XFree 86 server log
Comment 3 Nicholas Clark 2002-06-21 06:22:21 EDT
Created attachment 62006 [details]
XFree 86 server log
Comment 4 Mike A. Harris 2002-06-22 04:38:55 EDT
Please attach your /var/log/messages file, this looks like it may be
a kernel problem.

Also please provide the output of:

uname -a

rpm -qa | grep kernel

cat /proc/cpuinfo

lsmod


Thanks
Comment 5 Mike A. Harris 2002-06-22 04:41:33 EDT
Oh, by the way... since you mentioned gdb, if you're interested in debugging
this further yourself you can try out the special gdb I have for XFree86
which is available from:

ftp://people.redhat.com/mharris/gdb-xfree86

You can uninstall the standard gdb, and replace it with this one, and it
should be completely compatible, but allow debugging of the full modular
X server as well.

Rebuilding the X RPM's by defining DebuggableBuild 1 in the XFree86.spec
file, produces a fully debuggable rpmified X installation, with special
debug code et al. which further helps in debugging.

Hope this helps.
Comment 6 Nicholas Clark 2002-06-27 10:46:04 EDT
Created attachment 62864 [details]
/var/log/messages from time of most recent server crash, as requested
Comment 7 Nicholas Clark 2002-06-27 10:47:53 EDT
Other info as requested:

$ uname -a      
Linux localhost.localdomain 2.4.7-10 #1 Thu Sep 6 17:27:27 EDT 2001 i686 

$ rpm -qa | grep kernel
kernel-2.4.7-10
kernel-headers-2.4.7-10

$ cat /proc/cpuinfo 
processor
: 0
vendor_id
: GenuineIntel
cpu family	: 6
model
	: 8
model name	: Pentium III (Coppermine)
stepping
: 3
cpu MHz		: 730.971
cache size	: 256 KB
fdiv_bug
: no
hlt_bug
	: no
f00f_bug
: no
coma_bug
: no
fpu
	: yes
fpu_exception
: yes
cpuid level	: 2
wp
	: yes
flags
	: fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips
: 1458.17

$ lsmod
Module                  Size  Used by    
ide-cd                 27072   0 (autoclean)
cdrom                  28544   0 (autoclean) [ide-cd]
soundcore               4452   0 (autoclean)
i810                   65976   0
agpgart                27584   6 (autoclean)
binfmt_misc             6404   1
autofs                 11492   0 (autoclean) (unused)
3c59x                  26344   1
ipchains               39176   0
usb-uhci               21540   0 (unused)
usbcore                51712   1 [usb-uhci]
ext3                   64624   3
jbd                    40992   3 [ext3]

Comment 8 Mike A. Harris 2003-01-15 08:52:13 EST
This issue is fixed in the latest Rawhide XFree86, and is testable
in our latest beta (phoebe).  Please reopen if the problem persists
in the newer release.

Note You need to log in before you can comment on or make changes to this bug.