Bug 672438 - register with --autosubscribe fails to bind to Entitlement Beta subpool
Summary: register with --autosubscribe fails to bind to Entitlement Beta subpool
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Devan Goodwin
QA Contact: John Sefler
URL:
Whiteboard:
: 637937 (view as bug list)
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2011-01-25 04:45 UTC by John Sefler
Modified: 2011-05-19 13:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:39:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description John Sefler 2011-01-25 04:45:08 UTC
Description of problem:
register with --autosubscribe is failing (in both the gui and cli) to bind to the "Red Hat Enterprise Linux Server Entitlement Beta..." subpool in the QA test environment.


Version-Release number of selected component (if applicable):
http://download.devel.redhat.com/devel/candidate-trees/RHEL6.1-20110121.0/ installed as the client with all Add-On products (Load Balancer, Resilient Storage, Scalable File System, High Availability)
[root@jsefler-betaqa-1 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.93.14-1.el6.x86_64
subscription-manager-0.93.14-1.el6.x86_64
subscription-manager-gnome-0.93.14-1.el6.x86_64


How reproducible:
always

Steps to Reproduce:
Using an activated personal account for the Entitlement Beta in the QA environment...
[root@jsefler-betaqa-1 ~]# subscription-manager register --username=jsefler-qabetauser-4 --password=redhat --autosubscribe
b3f9997d-e6dd-49c0-a01f-3971584ec84f jsefler-betaqa-1.usersys.redhat.com
[root@jsefler-betaqa-1 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Load Balancer (for RHEL Entitlement)
Status:             	Not Subscribed           
Expires:            	                         
Subscription:       	                         
ContractNumber:     	                         
AccountNumber:      	                         


ProductName:        	Red Hat Enterprise Linux Resilient Storage (for RHEL Entitlement)
Status:             	Not Subscribed           
Expires:            	                         
Subscription:       	                         
ContractNumber:     	                         
AccountNumber:      	                         


ProductName:        	Red Hat Enterprise Linux Scalable File System (for RHEL Entitlement)
Status:             	Not Subscribed           
Expires:            	                         
Subscription:       	                         
ContractNumber:     	                         
AccountNumber:      	                         


ProductName:        	Red Hat Enterprise Linux High Availability (for RHEL Entitlement)
Status:             	Not Subscribed           
Expires:            	                         
Subscription:       	                         
ContractNumber:     	                         
AccountNumber:      	                         


ProductName:        	Red Hat Enterprise Linux Entitlement
Status:             	Not Subscribed           
Expires:            	                         
Subscription:       	                         
ContractNumber:     	                         
AccountNumber:      	                         


^^^^^  ALL OF THOSE STATUS LINES SHOULD HAVE SAID SUBSCRIBED.  AS YOU CAN SEEN FROM THE FOLLOWING list --available, THE PROVIDING SUBSCRIPTION SUBPOOL IS AVAILABLE.

[root@jsefler-betaqa-1 ~]# subscription-manager list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+


ProductName:       	Red Hat Enterprise Linux Server Entitlement Beta for
                        Certified Engineers and System Administrators - NOT FOR SALE
ProductId:         	RH3036913                
PoolId:            	8a9b90882da9ac9f012da9e5e991000e
Quantity:          	9                        
Expires:           	2011-07-19  

IN FACT, IF WE MANUALLY SUBSCRIBE TO IT, THEN YOU'LL SEE THE list --installed CHANGE TO WHAT WE EXPECTED AFTER THE register --autosubscribe

[root@jsefler-betaqa-1 ~]# subscription-manager subscribe --pool=8a9b90882da9ac9f012da9e5e991000e
[root@jsefler-betaqa-1 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+

ProductName:        	Red Hat Enterprise Linux Load Balancer (for RHEL Entitlement)
Status:             	Subscribed               
Expires:            	2011-07-19               
Subscription:       	81295930350728191        
ContractNumber:     	2117596                  
AccountNumber:      	1407378                  


ProductName:        	Red Hat Enterprise Linux Resilient Storage (for RHEL Entitlement)
Status:             	Subscribed               
Expires:            	2011-07-19               
Subscription:       	81295930350728191        
ContractNumber:     	2117596                  
AccountNumber:      	1407378                  


ProductName:        	Red Hat Enterprise Linux Scalable File System (for RHEL Entitlement)
Status:             	Subscribed               
Expires:            	2011-07-19               
Subscription:       	81295930350728191        
ContractNumber:     	2117596                  
AccountNumber:      	1407378                  


ProductName:        	Red Hat Enterprise Linux High Availability (for RHEL Entitlement)
Status:             	Subscribed               
Expires:            	2011-07-19               
Subscription:       	81295930350728191        
ContractNumber:     	2117596                  
AccountNumber:      	1407378                  


ProductName:        	Red Hat Enterprise Linux Entitlement
Status:             	Subscribed               
Expires:            	2011-07-19               
Subscription:       	81295930350728191        
ContractNumber:     	2117596                  
AccountNumber:      	1407378             

  
^^^  THAT'S WHAT WE EXPECTED AUTOSUBSCRIBE TO DO.

Comment 1 John Sefler 2011-01-25 04:47:38 UTC
This may be a duplicate of bugzilla #637937, nevertheless it is newer and VERY relevant to the Entitlement Beta.

Comment 2 Devan Goodwin 2011-01-25 15:28:37 UTC
Probably also a dupe of #671246, another pool that has no provided products:

curl -k -u jsefler-qabetauser-4:redhat https://subscriptions.rhn.webqa.redhat.com:443/subscription/pools/8a9b90882da9ac9f012da9e5e991000e

"providedProducts": [], 

I will get someone in IT to trigger the refresh, and also see if there's some way we could kick off a refresh for all pools out there.

Comment 3 Devan Goodwin 2011-01-25 16:35:19 UTC
Ok IT has refreshed pool 8a9b90882da0e33a012da57148890132 and it now has provided products.

HOWEVER, this will not trickle down to the sub-pool, you must revoke the "personal" entitlement in the web UI and then bind again.

This may crop up for other beta subscriptions created last week. If it looks like your subscription can't match anything on the system, it probably does not have these provided products and we need to get IT to refresh your subscriptions.

Comment 4 Devan Goodwin 2011-01-25 16:36:05 UTC
Jesus says you can un-entitle by selecting the person consumer in the web UI and choosing Remove from the drop-down.

Comment 5 Devan Goodwin 2011-01-25 16:36:46 UTC
*** Bug 637937 has been marked as a duplicate of this bug. ***

Comment 6 John Sefler 2011-01-25 23:23:17 UTC
Nope...  comment #3 and #4 did not fix the autosubscribe.

I tried to start over and created a brand new Entitlement Beta user on QA env through the Entitlement Enrollment App and created a personal subpool just like a beta customer will do.  Then I tried to register with autosubscribe and it does not work.  This is a problem.  Maybe its not a problem with candlepin, but it will be a BETA user experience problem.

[root@jsefler-betaqa-1 ~]# cd /etc/pki/product/
[root@jsefler-betaqa-1 product]# ls
3.pem  4.pem  5.pem  6.pem  7.pem
[root@jsefler-betaqa-1 product]# subscription-manager register --username=jsefler-qabetauser-01 --password=redhat --autosubscribe
cab5d9de-868d-4464-8e28-532afb7af23b jsefler-betaqa-1.usersys.redhat.com
[root@jsefler-betaqa-1 product]# subscription-manager list --installed | grep Status
    Installed Product Status
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
Status:             	Not Subscribed           
[root@jsefler-betaqa-1 product]#

Comment 7 John Sefler 2011-01-26 15:41:25 UTC
[root@jsefler-betaqa-1 product]# curl -k -u jsefler-qabetauser-01:redhat https://subscriptions.rhn.webqa.redhat.com:443/subscription/pools
[{"id":"8a9b90882da9ac9f012dbf4201031cb1","attributes":[],"owner":{"href":"/owners/6240362","id":"8a9b90882da9ac9f012dbf2e05d71c90"},"startDate":"2011-01-25T05:00:00.000+0000","href":"/pools/8a9b90882da9ac9f012dbf4201031cb1","providedProducts":[{"id":"8a9b90882da9ac9f012dbf427e781cb9","productName":"Red Hat Enterprise Linux Resilient Storage (for RHEL Entitlement)","productId":"6","updated":"2011-01-25T22:19:22.000+0000","created":"2011-01-25T22:19:22.000+0000"},{"id":"8a9b90882da9ac9f012dbf427e791cbc","productName":"Red Hat Enterprise Linux Load Balancer (for RHEL Entitlement)","productId":"5","updated":"2011-01-25T22:19:22.000+0000","created":"2011-01-25T22:19:22.000+0000"},{"id":"8a9b90882da9ac9f012dbf427e781cb8","productName":"Red Hat Enterprise Linux High Availability (for RHEL Entitlement)","productId":"4","updated":"2011-01-25T22:19:22.000+0000","created":"2011-01-25T22:19:22.000+0000"},{"id":"8a9b90882da9ac9f012dbf427e791cbb","productName":"Red Hat Enterprise Linux Scalable File System (for RHEL Entitlement)","productId":"7","updated":"2011-01-25T22:19:22.000+0000","created":"2011-01-25T22:19:22.000+0000"},{"id":"8a9b90882da9ac9f012dbf427e791cba","productName":"Red Hat Enterprise Linux Entitlement","productId":"3","updated":"2011-01-25T22:19:22.000+0000","created":"2011-01-25T22:19:22.000+0000"}],"endDate":"2011-07-25T03:59:59.000+0000","quantity":1,"productName":"Red Hat Enterprise Linux Server Entitlement Beta for Certified Engineers and System Administrators - NOT FOR SALE","contractNumber":"2117778","accountNumber":"1407677","subscriptionId":"1979218","productId":"RH3016037","consumed":1,"sourceEntitlement":null,"activeSubscription":true,"restrictedToUsername":null,"updated":"2011-01-25T22:20:36.000+0000","created":"2011-01-25T22:18:49.000+0000"},{"id":"8a9b90882da9ac9f012dbf43a0671cc1","attributes":[{"name":"requires_consumer_type","value":"system","updated":"2011-01-25T22:20:36.000+0000","created":"2011-01-25T22:20:36.000+0000"}],"owner":{"href":"/owners/6240362","id":"8a9b90882da9ac9f012dbf2e05d71c90"},"startDate":"2011-01-25T05:00:00.000+0000","href":"/pools/8a9b90882da9ac9f012dbf43a0671cc1","providedProducts":[],"endDate":"2011-07-25T03:59:59.000+0000","quantity":10,"productName":"Red Hat Enterprise Linux Server Entitlement Beta for Certified Engineers and System Administrators - NOT FOR SALE","contractNumber":"2117778","accountNumber":"1407677","subscriptionId":null,"productId":"RH3036913","consumed":0,"sourceEntitlement":{"href":"/entitlements/8a9b90882da9ac9f012dbf43a0671cc3","id":"8a9b90882da9ac9f012dbf43a0671cc3"},"activeSubscription":true,"restrictedToUsername":"jsefler-qabetauser-01","updated":"2011-01-25T22:20:36.000+0000","created":"2011-01-25T22:20:36.000+0000"}][root@jsefler-betaqa-1 product]# 


^^^ LOOKING AT ALL THE /pools FOR THIS NEW USER (jsefler-qabetauser-01), IT APPEARS THAT THE subpool HAS NO "providedProducts":[]....
MAYBE THIS IS THE CAUSE FOR FAILED AUTOSUBSCRIBES TO A SUBPOOL?


# curl -k -u jsefler-qabetauser-01:redhat https://subscriptions.rhn.webqa.redhat.com:443/subscription/pools/8a9b90882da9ac9f012dbf43a0671cc1
{"id":"8a9b90882da9ac9f012dbf43a0671cc1","attributes":[{"name":"requires_consumer_type","value":"system","updated":"2011-01-25T22:20:36.000+0000","created":"2011-01-25T22:20:36.000+0000"}],"owner":{"href":"/owners/6240362","id":"8a9b90882da9ac9f012dbf2e05d71c90"},"startDate":"2011-01-25T05:00:00.000+0000","href":"/pools/8a9b90882da9ac9f012dbf43a0671cc1","providedProducts":[],"endDate":"2011-07-25T03:59:59.000+0000","quantity":10,"productName":"Red Hat Enterprise Linux Server Entitlement Beta for Certified Engineers and System Administrators - NOT FOR SALE","contractNumber":"2117778","accountNumber":"1407677","subscriptionId":null,"productId":"RH3036913","consumed":0,"sourceEntitlement":{"href":"/entitlements/8a9b90882da9ac9f012dbf43a0671cc3","id":"8a9b90882da9ac9f012dbf43a0671cc3"},"activeSubscription":true,"restrictedToUsername":"jsefler-qabetauser-01","updated":"2011-01-25T22:20:36.000+0000","created":"2011-01-25T22:20:36.000+0000"}[root@jsefler-betaqa-1 product]#

Comment 8 Devan Goodwin 2011-01-26 16:09:21 UTC
Confirmed, this is broken in Candlepin, it was missed in the test coverage and the provided products are not being copied. Working on a fix.

Comment 9 Devan Goodwin 2011-01-27 15:01:25 UTC
Fixed in candlepin.git beta: 2c4916b9b1df8980ae4cb140e4353957ee796c77
in master: 340f5c5df11bc4b987ec17d1729030062b26e319

Going to do a rebuild and go straight to IT to get deployed ASAP.

Comment 11 John Sefler 2011-01-28 23:41:25 UTC
Verifying Candlepin Version...
[root@jsefler-betaqa-1 ~]# curl -k  -u foo:bar --request GET https://subscriptions.rhn.webqa.redhat.com:443/subscription/status | python -mjson.tool
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0    56    0    56    0     0     26      0 --:--:--  0:00:02 --:--:--    30
{
    "release": "1%{?dist}", 
    "result": true, 
    "version": "0.1.32"
}


[root@jsefler-betaqa-1 ~]# cd /etc/pki/product/
[root@jsefler-betaqa-1 product]# ls
3.pem  4.pem  5.pem  6.pem  7.pem
[root@jsefler-betaqa-1 product]# subscription-manager register --username=jsefler-qabetauser-10 --password=redhat --autosubscribe
3722d759-869f-4a18-82e3-980a7817ea22 jsefler-betaqa-1.usersys.redhat.com
Subscribed to Products:
     Red Hat Enterprise Linux Entitlement(3)
     Red Hat Enterprise Linux Resilient Storage (for RHEL Entitlement)(6)
     Red Hat Enterprise Linux Load Balancer (for RHEL Entitlement)(5)
     Red Hat Enterprise Linux Scalable File System (for RHEL Entitlement)(7)
     Red Hat Enterprise Linux High Availability (for RHEL Entitlement)(4)
[root@jsefler-betaqa-1 product]# subscription-manager list --installed | grep Status
    Installed Product Status
Status:             	Subscribed               
Status:             	Subscribed               
Status:             	Subscribed               
Status:             	Subscribed               
Status:             	Subscribed    

Moving to VERIFIED

Comment 12 errata-xmlrpc 2011-05-19 13:39:12 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.