Bug 67261 - Disk Druid fails to give warning when boot partition is too small druing NFS installation
Disk Druid fails to give warning when boot partition is too small druing NFS ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: anaconda (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 12:51 EDT by Need Real Name
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 16:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-21 12:51:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461; .NET 
CLR 1.0.3705)

Description of problem:
No warning given when boot partition is set too small in disk set up screen 
for Disk Druid during a NFS installation. We have seen the disk set-up screen 
for RH 7.3 Professional give a pop-up warning if the boot partition is not set 
correctly. With RH 2.1 AS, we did not receive a pop-up warning until 
the 'installing packages' screen which was too far into the installation 
process for a warning of that type to be useful. The installation had to be 
started from the beginning due to the inability to return to the disk set up 
screen for disk druid. -H/W specs Compaq ProLiant ML570, 3GB memory, (4) 900 
MHz processors, (1) Compaq 34.9GB Ultra3-SCSI 10K HDD.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1)Boot system to a bootnet.img diskette made from RH 2.1 AS Cd.
2)Install via a NFS image on a RH 2.1 AS NFS server with shared installation 
images.
3)select to manually partition drive with disk druid. Delete all partitions.
4)In the 'disk set-up' screen do the following
5)select 'new' and make boot partition 20mb and check 'force to be a primary 
partition'
6)select 'new' and make swap partition 1000mb and check 'force to be a primary 
partition'
7)select 'new' and make / partition by selecting to 'fill to maximum allowable 
size' and check 'force to be a primary partition'
8)This is where we've seen this the boot partition warning before. The warning 
typically reads, boot partition too small go back and make changes
6)There was no warning given. Not until this system was at the 'installing 
packages' installation screen did we see this warning.

	

Actual Results:  Pop-up warning during 'package install' screen. Install had 
to be restarted.

Expected Results:  Warning before leaving disk set-up installation screen.

Additional info:
Comment 1 Jeremy Katz 2002-06-21 15:47:02 EDT
With Advanced Server, the warning for /boot only appeared if you were at less
than 20 megs.
Comment 2 Need Real Name 2002-06-21 16:10:43 EDT
The /boot was set to 20MB
Comment 3 Need Real Name 2002-06-21 16:14:10 EDT
In addition, the pop-up warning should be give prior to leaving the 'disk 
setup screen', when the user has a chance to remedy the error. Right now, when 
the user sees the 'pop-up' warning re: /boot partition size being too small 
it's too late to do anything about it. A reinstallation is required.
Comment 4 Jeremy Katz 2002-06-21 16:59:19 EDT
We can't tell exactly how much space is required until after we've loaded the
full header lists, which may require turning on swap and thus after we've
committed your partitioning changes to disk.  There are guidelines which are in
the installer which we warn you at -- with Red Hat Linux Advanced Server, the
warning for /boot is triggered by having the partition be less than 20 megs. 
That doesn't always mean that you need 20 megs or that 20 megs is always enough,
but it's a rule of thumb sort of thing.

Note You need to log in before you can comment on or make changes to this bug.