This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 672613 - pylorax.yumhelper.ERROR: cannot erase util-linux-ng: Package not installed
pylorax.yumhelper.ERROR: cannot erase util-linux-ng: Package not installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-25 12:59 EST by John Reiser
Modified: 2013-07-04 08:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: lorax-0.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-26 05:16:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2011-01-25 12:59:35 EST
Description of problem: During a pungi run, pylorax.yumhelper complains about util-linux-ng not being installed.


Version-Release number of selected component (if applicable):
lorax-0.3-1.fc15

How reproducible: every time


Steps to Reproduce:
1. compose install DVD using pungi
2.
3.
  
Actual results:pylorax.yumhelper.ERROR: cannot erase util-linux-ng: Package not installed



Expected results: no complaint


Additional info: In the pungi .log file, all mentions of 'util-linux' after the download list are given below.  Note the _missing_ "using local copy of util-linux-ng".
-----
yum.verbose.YumBase.DEBUG: using local copy of util-linux-2.19-0.2.fc15.x86_64
yum.verbose.YumBase.DEBUG: TSINFO: Marking util-linux-2.19-0.2.fc15.x86_64 as install for anaconda-15.16-1.fc15.x86_64
yum.verbose.YumBase.DEBUG: TSINFO: Marking libmount-2.19-0.2.fc15.x86_64 as install for util-linux-2.19-0.2.fc15.x86_64
yum.verbose.YumBase.DEBUG: using local copy of util-linux-2.19-0.2.fc15.x86_64
pylorax.yumhelper.DEBUG: util-linux-2.19-0.2.fc15.x86_64 installed successfully
pylorax.DEBUG: util-linux-ng	['/bin/findmnt', '/bin/taskset', '/etc/pam.d/chfn', '/etc/pam.d/chsh', '/sbin/addpart', '/sbin/agetty', '/sbin/cfdisk', '/sbin/ctrlaltdel', '/sbin/delpart', '/sbin/findfs', '/sbin/fsck.cramfs', '/sbin/fsfreeze', '/sbin/mkfs', '/sbin/mkfs.cramfs', '/sbin/partx', '/sbin/pivot_root', '/sbin/swaplabel', '/sbin/switch_root', '/usr/bin/cal', '/usr/bin/chfn', '/usr/bin/chrt', '/usr/bin/chsh', '/usr/bin/col', '/usr/bin/colcrt', '/usr/bin/colrm', '/usr/bin/column', '/usr/bin/ddate', '/usr/bin/fallocate', '/usr/bin/flock', '/usr/bin/floppy', '/usr/bin/getopt', '/usr/bin/hexdump', '/usr/bin/i386', '/usr/bin/ionice', '/usr/bin/ipcmk', '/usr/bin/ipcrm', '/usr/bin/ipcs', '/usr/bin/isosize', '/usr/bin/kill', '/usr/bin/linux32', '/usr/bin/linux64', '/usr/bin/look', '/usr/bin/lscpu', '/usr/bin/mcookie', '/usr/bin/namei', '/usr/bin/rename', '/usr/bin/renice', '/usr/bin/rev', '/usr/bin/script', '/usr/bin/scriptreplay', '/usr/bin/setarch', '/usr/bin/setsid', '/usr/bin/setterm', '/usr/bin/tailf', '/usr/bin/ul', '/usr/bin/unshare', '/usr/bin/uuidgen', '/usr/bin/whereis', '/usr/bin/write', '/usr/bin/x86_64', '/usr/sbin/fdformat', '/usr/sbin/hwclock', '/usr/sbin/ldattach', '/usr/sbin/readprofile', '/usr/sbin/rtcwake', '/usr/sbin/tunelp', '/usr/share/locale/*']
pylorax.yumhelper.ERROR: cannot erase util-linux-ng: Package not installed
-----
Comment 1 Martin Gracik 2011-01-26 05:12:15 EST
That looks like the util-linux-ng package changed to util-linux
Comment 2 Martin Gracik 2011-01-26 05:16:04 EST
Fixed in lorax-0.4-1

Note You need to log in before you can comment on or make changes to this bug.