Bug 67264 - /etc/profile.d/vim.sh only applies to the bash shell
Summary: /etc/profile.d/vim.sh only applies to the bash shell
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 7.3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-21 17:31 UTC by Nathan G. Grennan
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 17:31:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan G. Grennan 2002-06-21 17:31:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
/etc/profile.d/vim.sh only applies to the bash shell because of the line below.
Other shells that use /etc/profile, like zsh, can use the alias defined in
vim.sh just fine, but are excluded by the if statement.

if echo $SHELL |grep bash 2>&1 >/dev/null; then # aliases are bash only





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install vim-enhanced and zsh
2. chsh -s zsh user
3. Login as user
4. vi filename
	

Actual Results:  Text isn't color coded.

Expected Results:  Text is color coded.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.