Bug 672647 - forgot _isa when packaging .rpm for 'report'
forgot _isa when packaging .rpm for 'report'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: report (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Gavin Romig-Koch
BaseOS QE - Apps
:
Depends On: 670215
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-25 14:40 EST by Gavin Romig-Koch
Modified: 2011-05-19 10:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: report-0.18-8.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 670215
Environment:
Last Closed: 2011-05-19 10:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gavin Romig-Koch 2011-01-25 14:40:30 EST
+++ This bug was initially created as a clone of Bug #670215 +++

Description of problem: Rpm packaging of package 'report' forgot to specify _isa, which leads to mysterious errors when updating or installing other packages such as report-gtk.  See https://bugzilla.redhat.com/show_bug.cgi?id=669842#c2, specifically:
-----
1. You have report-0.20-1.fc14.x86_64 installed.

2. You want to install report-gtk-0.20-0.fc15.x86_64, which has a dep. on repo
= 0.20-0.fc15 (an older version than what you have installed).

3. Yum won't auto downgrade the x86_64 version, and the package doesn't use
_isa, so yum thinks it can solve the problem by installing
report-0.20-0.fc15.i686.
-----

Version-Release number of selected component (if applicable):
report-0.20-1.fc14.x86_64

How reproducible:
every time

Steps to Reproduce:
1. Attempt to install report-gtk.x86_64 0:0.20-0.fc15 when report-0.20-1.fc14.x86_64 is installed.
2.
3.
  
Actual results:
Error: Protected multilib versions: report-0.20-0.fc15.i686 !=
report-0.20-1.fc14.x86_64


Expected results: smooth integration between 'report' and 'report-gtk', including no complaints about i686 on an all-x86_64 system.


Additional info: originally filed against yum as https://bugzilla.redhat.com/show_bug.cgi?id=669842
Comment 1 Gavin Romig-Koch 2011-01-26 13:44:43 EST
pushed upstream.
Comment 4 Gavin Romig-Koch 2011-02-17 13:42:00 EST
See Description on this bz; it has a description of what happens on x86_64 if you don't have _isa.
Comment 5 Gavin Romig-Koch 2011-02-17 17:10:11 EST
(In reply to comment #4)
> See Description on this bz; it has a description of what happens on x86_64 if
> you don't have _isa.

Sorry, I wasn't thinking when I said this.  You won't be able to test this (easily) more than you already have.   This change will not have any significant effect until at least two versions of report go out with this change.  At that point this change will prevent a customer from installing mismatched versions of (say) report and report-gtk.  There has always been a version specific dependency of report-gtk on report, which should prevent a report/report-gtk version mismatch, but without this _isa change, yum would 'work around' the version specific dependency by installing a different version of report (one that matched the version needed by report-gtk).

Of course, this version mismatch thing will never be a problem in the 'normal case' of a customer who only does updates from our official repos.  It could only ever be a problem for a customer who try's to downgrade to an old version incorrectly, or has some glitch while yum updating, or installs some packages outside of yum's control, or if we make a mistake and put the wrong package versions into our repo, or the wrong packages versions get put on the satellight they are using ....
Comment 6 John Reiser 2011-02-17 17:49:30 EST
(In reply to comment #5)
> Of course, this version mismatch thing will never be a problem in the 'normal
> case' of a customer who only does updates from our official repos.

"Never" is a very long time.  The problem _will_ happen if there is more than one repository and they are at different over-all versions, or in a single repository if the packages are updated non-atomically.  In practice is it hard to guarantee consistent versions due to reasons such as network delays, power outages, operator error or misunderstanding, etc.
Comment 8 errata-xmlrpc 2011-05-19 10:07:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0703.html

Note You need to log in before you can comment on or make changes to this bug.