Bug 67270 - rpm packages don't show up in the web UI channel package list after deleting & rhnpush
rpm packages don't show up in the web UI channel package list after deleting ...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 14:53 EDT by Bret Bassemier
Modified: 2007-07-31 15:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-25 12:29:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bret Bassemier 2002-06-21 14:53:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011126
Netscape6/6.2.1

Description of problem:
After deleting an rpm package through the web UI, uploading via rhnpush, the rpm
does not display in the channel package list and is not available for installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Delete an rpm package from a custom channel
2.Use rhnpush to upload the package deleted in step one
3.
	

Actual Results:  rhnpush finishes successfully - no errors reported.
The rpm package does not display in the package list of the custom channel.
Cannot install package using up2date - up2date reports 'There are no packages
available for update'

Expected Results:  Package listed in the channel package list and available for
installation via up2date.

Additional info:
Comment 1 Josef Komenda 2002-06-24 10:38:06 EDT
Does this mean that bug 67174 can be closed?
Comment 2 Josef Komenda 2002-06-25 14:18:25 EDT
There's no way to delete a package currently - disassociating a package from a
channel does not remove it, so that would explain why the attempt to use rhnpush
a 2nd time failed. If you want to re-associate a package with a channel, you go to:

Channel Management => Edit => Package List Tab
And select 'View packages in' [No Channels] from the pulldown.

You can then re-associate it with the channel. 

Comment 3 Mihai Ibanescu 2002-06-25 14:25:01 EDT
I could not reproduce it either. bretb, did you use --newest as a flag to
rhnpush, by any chance?

Note You need to log in before you can comment on or make changes to this bug.