Bug 67272 - "Unexpected dirty buffer encountered"
"Unexpected dirty buffer encountered"
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 14:59 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-24 10:56:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-21 14:59:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530

Description of problem:

Upgraded from RH7.2 to RH7.3

Whenever I execute 'lilo' to update my boot configuration,
I get the following error message:

"Unexpected dirty buffer encountered at do_get_write_access:597 (16:02 blocknr 0)"

System boots OK, so don't know what this message signifies.

Version-Release number of selected component (if applicable):
as per distribution

How reproducible:
Always

Steps to Reproduce:
execute 'lilo'

Actual Results:  see above

Expected Results:  see above

Additional info:
Comment 1 Jeremy Katz 2002-06-21 15:15:25 EDT
This is a message from the kernel
Comment 2 Stephen Tweedie 2002-06-21 17:25:13 EDT
Which kernel is this?

There are two possibilities here.  The message you are seeing occurs when ext3
sees a particular unexpected situation arise.  That can sometimes arise from
kernel bugs (which is why we have that warning), but it can also happen when you
have code interfering with ext3.

I suspect that you are just seeing the latter effect --- it is possible to see
this message when some external program tries to access a filesystem buffer
which is under ext3 control, and lilo may well be doing exactly that if you are
installing the boot record to an ext3 filesystem.  In that case, the warning is
entirely benign --- it is only there because this situation can sometimes
indicate a bug.  

The reason that this situation results merely in a log message, not a kernel
panic, is precisely because there are situations where it can arise legally.
Comment 3 Need Real Name 2002-06-22 21:27:38 EDT
This is RedHat kernel-2.4.18-5 (but ditto 2.4.18-4).

Would this somewhat unsettling message go away if I switched to 'grub'?
Comment 4 Stephen Tweedie 2002-06-24 10:56:13 EDT
No, not if you have grub configured to write its boot sector to the same place.
 Most people put their boot sectors on the disk MBR, though --- I think what's
happening is that you're booting via the boot sector at the beginning of a
subsidiary partition (eg. /dev/hda1) rather than the full disk itself
(/dev/hda), and using the latter form would avoid the message.
Comment 5 Need Real Name 2002-06-24 17:46:25 EDT
Exactly the case. Thank you.

Note You need to log in before you can comment on or make changes to this bug.