Bug 67291 - quota throws errror message (No such file or directory) when running amd (am-utils)
quota throws errror message (No such file or directory) when running amd (am-...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-21 18:45 EDT by Nicolas Bock
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 18:45:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Bock 2002-06-21 18:45:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020610

Description of problem:
When running amd from am-utils, an entry is generated in /etc/mtab, regardless
of whether anything is mounted on /net or not. This entry causes quota to
generate this error message:

quota: Error while getting quota from my_computer:(pid8267) for 3169: No such
file or directory

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start amd (/etc/init.d/amd start)
2."quota"
	

Actual Results:  Throws error message about some file not being found. This is
confusing at best, since no additional information is given by quota about to
what the actual problem is.

Expected Results:  This error shouldn't occur.

Additional info:
Comment 1 Phil Copeland 2002-08-07 11:21:33 EDT
Humm
Ok well I'll show the cut and paste of me using quota-3.06-x from rawhide which
is also scheduled as errata for 7.x

                  
Preparing...                ########################################### [100%]
   1:am-utils               ########################################### [100%]
[root@alpha quota-tools]# /etc/init.d/amd start
Starting amd:                                              [  OK  ]
[root@alpha quota-tools]# cat /etc/mtab
/dev/sda2 / ext3 rw 0 0
none /proc proc rw 0 0
usbdevfs /proc/bus/usb usbdevfs rw 0 0
/dev/sda1 /boot ext3 rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
none /dev/shm tmpfs rw 0 0
/dev/sda4 /tmp ext3 rw 0 0
intr,rw,port=1023,timeo=8,retrans=110,indirect,map=/etc/amd.net,dev=0000000c 0 0

[root@alpha quota-tools]# quota
Disk quotas for user root (uid 0): none

[root@alpha quota-tools]# 


Works for me!

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.