Bug 673014 - libgstladspa.so gives ld.so indigestion
Summary: libgstladspa.so gives ld.so indigestion
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 675581 678866 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-01-27 02:20 UTC by Valdis Kletnieks
Modified: 2016-11-24 15:44 UTC (History)
10 users (show)

Fixed In Version: glibc-2.13.90-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-13 04:40:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Sourceware 12454 None None None Never

Description Valdis Kletnieks 2011-01-27 02:20:39 UTC
Description of problem:
After upgrading to gstreamer-plugins-bad-free-0.10.21-1.fc15.x86_64, pidgin started dying at startup with message:

% pidgin 
Inconsistency detected by ld.so: dl-deps.c: 623: _dl_map_object_deps: Assertion `nlist > 1' failed!
%

Running strace pointed at /usr/lib64/gstreamer-0.10/libgstladspa.so and /usr/lib64/ladspa/amp.so as the last 2 libraries examined by ld.so, but ladspa was updated way back in 2009, while gstreamer-plugins-bad-free was updated today.

Doing an 'rpm -e --nodeps gstreamer-plugins-bad-free' allowed pidgin to start up correctly.

Am willing to do any further tracing/debugging needed.

Version-Release number of selected component (if applicable):
gstreamer-plugins-bad-free-0.10.21-1.fc15.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Thorsten Leemhuis 2011-02-14 07:27:53 UTC
FWIW, had the same problem -- I afaics fixed it by uninstalling ladspa, as mentioned in Bug 672849 ; gstreamer-plugins-bad-free-0.10.21-2.fc15.x86_64 still installed

/me wonders what the real cause of this is but leaves that to the experts

Comment 2 Benjamin Otte 2011-02-14 13:42:48 UTC
After someone mentioned this issue in gnome-settings-daemon, I started to google for it. I wonder if this is a duplicate of one or both of
https://bugzilla.redhat.com/show_bug.cgi?id=672849
https://bugzilla.redhat.com/show_bug.cgi?id=675581

So I suspect it's a glibc bug, assigning it there.

Comment 3 Valdis Kletnieks 2011-02-14 16:03:15 UTC
I believe Andreas Schwab has it pegged - Sourceware bug #12454 traced down to a glibc commit.

http://sourceware.org/bugzilla/show_bug.cgi?id=12454

Comment 4 Fedora Update System 2011-02-15 14:55:25 UTC
glibc-2.13.90-4 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/glibc-2.13.90-4

Comment 5 Thorsten Leemhuis 2011-02-15 15:04:55 UTC
(In reply to comment #4)
> glibc-2.13.90-4 has been submitted as an update for Fedora 15.
> https://admin.fedoraproject.org/updates/glibc-2.13.90-4

This fixed the issue for me (I let bodhi close this bug)

Comment 6 Valdis Kletnieks 2011-02-15 17:14:08 UTC
Confirming fixed in glibc-2.13.90-4.

Comment 7 Fedora Update System 2011-02-15 17:29:17 UTC
glibc-2.13.90-4 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glibc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/glibc-2.13.90-4

Comment 8 Honza Horak 2011-02-17 09:30:38 UTC
*** Bug 675581 has been marked as a duplicate of this bug. ***

Comment 9 Andreas Schwab 2011-02-21 08:45:04 UTC
*** Bug 678866 has been marked as a duplicate of this bug. ***

Comment 10 Vít Ondruch 2011-03-03 15:49:44 UTC
Can we get this into rawhide please?

Comment 11 Fedora Update System 2011-03-04 09:53:52 UTC
glibc-2.13.90-5 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glibc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/glibc-2.13.90-5

Comment 12 Fedora Update System 2011-03-13 04:40:22 UTC
glibc-2.13.90-6 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.