Bug 673047 - [abrt] ibus-1.3.9-2.fc14: ibus_xkb_get_current_layout: Process /usr/libexec/ibus-xkb was killed by signal 6 (SIGABRT)
[abrt] ibus-1.3.9-2.fc14: ibus_xkb_get_current_layout: Process /usr/libexec/i...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
14
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:f2ce5b80424e0f0c58006ba6bed...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-27 02:25 EST by kang.junghan
Modified: 2011-03-17 14:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: ibus-1.3.9-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-14 01:39:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (3.22 KB, text/plain)
2011-01-27 02:25 EST, kang.junghan
no flags Details

  None (edit)
Description kang.junghan 2011-01-27 02:25:34 EST
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: /usr/libexec/ibus-xkb --get
component: ibus
crash_function: ibus_xkb_get_current_layout
executable: /usr/libexec/ibus-xkb
kernel: 2.6.35.10-74.fc14.i686
package: ibus-1.3.9-2.fc14
rating: 4
reason: Process /usr/libexec/ibus-xkb was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1296156459
uid: 0

How to reproduce
-----
1.특이사항 잘 모르겠습니다.
2.
3.
Comment 1 kang.junghan 2011-01-27 02:25:38 EST
Created attachment 475544 [details]
File: backtrace
Comment 2 fujiwara 2011-01-27 20:18:02 EST
kang.junghan:

Do you see any warnings or errors when you run ibus-xkb on a terminal by manual?

% /usr/libexec/ibus-xkb --get
layout: us
model: 
option: 

Maybe I guess your system might not support XKB.
Comment 3 fujiwara 2011-02-03 04:59:05 EST
kang.junghan:

Do you have any updates?
Comment 4 David Björkevik 2011-03-01 03:38:34 EST
Package: ibus-1.3.9-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Start GNOME in a thinlinc (vnc) session
Comment 5 David Björkevik 2011-03-01 03:41:02 EST
As in comment 4, this happens in a VNC session.

[david@peregrine ~]$ /usr/libexec/ibus-xkb --get

** (ibus-xkb:5657): WARNING **: Could not get state
**
ERROR:xkblib.c:245:ibus_xkb_get_current_layout: assertion failed: (default_layouts != NULL)
Aborted (core dumped)
Comment 6 David Björkevik 2011-03-01 04:09:06 EST
According to a Thinlinc developer, the crash happens because their VNC server is combiled without XKB-support. It would be nice for ibus-xkb to handle this case more gracefully than a SIGABRT.
Comment 7 fujiwara 2011-03-01 04:20:04 EST
(In reply to comment #5)
> As in comment 4, this happens in a VNC session.
> 
> [david@peregrine ~]$ /usr/libexec/ibus-xkb --get
> 
> ** (ibus-xkb:5657): WARNING **: Could not get state
> **
> ERROR:xkblib.c:245:ibus_xkb_get_current_layout: assertion failed:
> (default_layouts != NULL)
> Aborted (core dumped)

Thanks for the report.
It seems the VNC session doesn't use the core keyboard and XkbGetState (xdisplay, XkbUseCoreKbd, &state) was failed.

I'll remove it. 
Also could you check if the _XKB_RULES_NAMES atom is available on your VNC session?

% xlsatoms | grep _XKB_RULES_NAMES
262	_XKB_RULES_NAMES
Comment 8 David Björkevik 2011-03-01 04:26:11 EST
Thanks!

The atom doesn't seem to be present:

[david@peregrine ~]$ xlsatoms | grep _XKB_RULES_NAMES
[david@peregrine ~]$
Comment 9 fujiwara 2011-03-01 04:33:30 EST
(In reply to comment #8)

Oh, it seems the session doesn't support XKB completely.
Thanks for your info.
Comment 10 Fedora Update System 2011-03-11 13:52:52 EST
ibus-1.3.99.20110228-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110228-2.fc15
Comment 11 Fedora Update System 2011-03-11 13:53:00 EST
ibus-1.3.9-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ibus-1.3.9-3.fc14
Comment 12 Fedora Update System 2011-03-14 01:39:26 EDT
ibus-1.3.99.20110228-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2011-03-17 14:51:31 EDT
ibus-1.3.9-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.