This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 673062 - KEYTABLE=emacs causes upgrade to fail
KEYTABLE=emacs causes upgrade to fail
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
12
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-27 03:54 EST by James Tanis
Modified: 2011-11-09 15:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-09 15:10:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Tanis 2011-01-27 03:54:18 EST
Description of problem:
I am trying to upgrade from 12 to 13 using preupgrade. After I reboot and the software install part (I assume) begins, the python codes chokes on what appears to be the fact that I chose to use a configuration where KEYTABLE=emacs instead of default (and presumably heavily tested) "us" (this is of course, because the "emacs" layout puts the control key where God *himself* intended it -- no really, it's in one of the later epistles...I swear). I have now seen this happen at least 3 separate times. In this latest attempt, once I was rebooted back into F12, I reverted /etc/sysconfig/keboard and tried the preupgrade process again, but I think the old keyboard layout information got cached somewhere because the upgrade choked in the exact same way (with the same python traceback) and I know that the *only* file I changed to get the emacs layout was /etc/sysconfig/keyboard. I did try to save the bug information and the tool claimed that it was saved -- and *apparently* somewhere in /root, but I have not been able to locate it :-( Sorry about that. 

I should also mention that my /boot was too small to handle whatever it was the preupgrade wanted to throw in there, so I got that warning dialog, but since I this was a wired machine, I was able to simply defer the operation until after the reboot. 

Version-Release number of selected component (if applicable):
preupgrade-1.1.8-1.fc12.1.noarch

How reproducible:
Very. It has happened to every attempt I've made to upgrade from 12 to 13 and I believe also on one attempt to upgrade 10 to 11 (I do run a boatload of fedora machines here at home)

Steps to Reproduce:
1. Load F12 on a wired machine with a small /boot that won't allow preupgrade to do whatever it is that having a small /boot won't allow preupgrade to do.
2. Update /etc/syconfig/keyboard so that KEYTABLE="emacs"
3. Yum up to the latest (I dunno if this is strictly necessary)
4. Run preupgrade and follow the instructions. 
5. At some point, after the reboot, while trying to load /install.img, the error should appear. 
  
Additional info:
I realize that this is not a high priority ticket since only idiots like me muck with /etc/sysconfig/keyboard, but I put the severity at "Urgent" because for those poor sods who *do* tickle this bug, on-line upgrades are an impossibility (well -- that may not be true. I have not tried reverting /etc/sysconfig/keyboard before running preupgrade for the first time -- I image that would avoid the problem).
Comment 1 John Poelstra 2011-11-09 15:10:52 EST
    Thank you for your bug report. 

    We are sorry, but the Fedora Project is no longer releasing bug fixes or any other updates for Fedora 12. This bug will be set to CLOSED:WONTFIX to reflect this, but please reopen it if the problem persists after upgrading to the latest version of Fedora, which is available from: 

    http://fedoraproject.org/get-fedora

Note You need to log in before you can comment on or make changes to this bug.