Bug 67312 - (NET 3C59X) 3com 905B fails to link using 3c59x module
(NET 3C59X) 3com 905B fails to link using 3c59x module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-22 00:27 EDT by Charles Schwer
Modified: 2013-07-02 22:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Schwer 2002-06-22 00:27:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020617

Description of problem:
After upgrading to kernel-2.4.18-5, 3com 905b-TX nic fails to link with switch.
 ifconfig shows interface as up, however a link light never shows up on the
switch and I cannot see anything on the network.  I am using the 3c59x module
with options=8.  This works fine with the 2.4.18-4 kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install kernel 2.4.18-5
2.reboot

Actual Results:  nic failed to link with D-Link switch

Expected Results:  nic should have linked at 100 mbps at full duplex

Additional info:

this is a dual celeron machine with a 3com 905b-TX nic with WOL.  It is
connected to a D-Link DSS-5+ switch.  I am using the smp kernel, however i
reproduced the problem with the smp kernel and the standard kernel.
Comment 1 Arjan van de Ven 2002-06-22 05:08:34 EDT
Does it still fail if you don't pass the options field ?
Comment 2 Arjan van de Ven 2002-06-22 10:50:36 EDT
could you also try 2.4.18-5a from
http://people.redhat.com/arjanv/testkernels?
Comment 3 Charles Schwer 2002-06-23 03:41:19 EDT
I removed the options= field and the nic links at 10mbps and half duplex with
the 2.4.18-5 kernel.
I tried the 2.4.18-5a kernel with options=8 it links properly at 100mbps and
full duplex and without the options= it links at 10mbps and half duplex again.
Comment 4 Bugzilla owner 2004-09-30 11:39:41 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.