Bug 673222 - Fix libdfp 1.0.6 testsuite failures on s390 when using hardware support
Fix libdfp 1.0.6 testsuite failures on s390 when using hardware support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libdfp (Show other bugs)
6.1
s390x Unspecified
high Severity high
: rc
: 6.1
Assigned To: Andreas Schwab
qe-baseos-tools
:
Depends On:
Blocks: 642693 684385
  Show dependency treegraph
 
Reported: 2011-01-27 13:29 EST by Joseph Kachuck
Modified: 2011-06-24 10:44 EDT (History)
4 users (show)

See Also:
Fixed In Version: libdfp-1.0.6-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libdfp-s390-fix (2.07 KB, patch)
2011-01-27 13:30 EST, Joseph Kachuck
no flags Details | Diff

  None (edit)
Description Joseph Kachuck 2011-01-27 13:29:10 EST
---Problem Description---
libdfp testsuite failures in the S/390 hardware version.

---Steps to Reproduce---
make check in the libdfp build dir

RedHat requested to track further libdfp problems in separate bugzillas. This
bugzilla is about a problem which occurred after the last libdfp version 1.0.6
which used RedHat for rebasing.

> 1.Server architecture(s) (please list all effected) (x86/POWER6/Z/etc.):
s390x
> 2.Server type (9117-MMA/HS20/s390/etc.):
s390
> 3.General component (desktop/kernel/base OS/dev tools/etc.):
dev tools
> 4.Other components involved (ixgbe/java/emulex/etc.):
none
> 5.Does the server have the latest GA firmware?
yes
> 6.Has the problem been shown to occur on more than one system?
yes
> 7.Is a tested patch available?
yes, see attachement
> If yes to the above, has it been approved upstream?
yes, it is part of libdfp 1.0.7
> 8.What is the latest official Red Hat build on which this bug has been
> seen?
RHEL 6
Comment 1 Joseph Kachuck 2011-01-27 13:30:39 EST
Created attachment 475662 [details]
libdfp-s390-fix
Comment 2 Joseph Kachuck 2011-01-27 13:32:03 EST
IBM Update:
Run the libdfp testsuite in the build directory with:
make check

The hardware variant of libdfp on s390 produces failures in the testsuite:

In the build dir after make check: ls -l *.out

-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-amort.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-decode.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-fpclassify.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-get_digits.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-isfinite.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-isinf.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-isnan.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-log10d.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-logd.out
-rw------- 1 krebbel krebbel 1804 2011-01-27 17:16 test-numdigits.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-param.out
-rw------- 1 krebbel krebbel 5092 2011-01-27 17:16 test-printf.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-quantize.out
-rw------- 1 krebbel krebbel  816 2011-01-27 17:16 test-round.out
-rw------- 1 krebbel krebbel    0 2011-01-27 17:16 test-strtod.out

The patch fixes the 3 bugs above in the s390 implementation of numdigits, setexp and __fe_dec_setround.
Comment 3 IBM Bug Proxy 2011-03-26 13:25:13 EDT
------- Comment From krebbel@linux.vnet.ibm.com 2011-01-27 11:22 EDT-------
(In reply to comment #7)
> Hello,
> Please send soem details on what the problem is that you are seeing. Any error
> messages.
> Please also provide steps to reproduce this issue.






------- Comment From prem.karat@linux.vnet.ibm.com 2011-03-01 07:35 EDT-------
(In reply to comment #9)
> Hello,
> I have sent this up for engineering to review.
>
> Thank You
> Joe Kachuck

Hi Joe

Did you hear back from your engineering team?

Cheers,
Prem
Comment 4 IBM Bug Proxy 2011-03-31 16:33:49 EDT
------- Comment From mgrf@de.ibm.com 2011-03-31 16:22 EDT-------
Hi Joe, John,

based on our calls libdfp should get these fixes for R 6.1.
If verification fail we should open a new BZ.

Seems we can just continue to use this ?
Comment 7 IBM Bug Proxy 2011-04-02 09:51:18 EDT
------- Comment From rsa@us.ibm.com 2011-04-02 09:44 EDT-------
(In reply to comment #14)
> Hi Joe, John,
>
> based on our calls libdfp should get these fixes for R 6.1.
> If verification fail we should open a new BZ.
>
> Seems we can just continue to use this ?

I checked the src rpm for the latest RHEL 6.1 supplemental and these fixes are not in place.
Comment 9 John Jarvis 2011-04-07 13:37:42 EDT
The fix for this bug is included in snapshot 2 which went out to partners on April 6.  Please test and provide feedback.
Comment 10 IBM Bug Proxy 2011-04-12 11:52:32 EDT
------- Comment From mgrf@de.ibm.com 2011-04-12 11:47 EDT-------
This is verified on System z on R 6.1 snapshot 2 - closing on IBM site Thx
Comment 12 errata-xmlrpc 2011-05-19 09:53:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0659.html

Note You need to log in before you can comment on or make changes to this bug.