Bug 67341 - INFO/OBSOLETES always empty in #rpm view
Summary: INFO/OBSOLETES always empty in #rpm view
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-22 23:57 UTC by Miloslav Trmac
Modified: 2013-07-02 22:56 UTC (History)
3 users (show)

Fixed In Version: 4.6.1-0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 16:23:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (583 bytes, patch)
2002-06-22 23:58 UTC, Miloslav Trmac
no flags Details | Diff
trivial patch to mc 4.6.0 (/usr/share/mc/extfs/rpm) (1.79 KB, patch)
2003-07-10 21:17 UTC, Paul Bolle
no flags Details | Diff
patch against mc-4.6.0-14.10 (569 bytes, patch)
2004-05-09 13:14 UTC, Leonard den Ottolander
no flags Details | Diff
Add INFO/OBSOLETES and INFO/LICENSE to rpm view (1.17 KB, patch)
2004-08-22 11:11 UTC, Leonard den Ottolander
no flags Details | Diff

Description Miloslav Trmac 2002-06-22 23:57:33 UTC
Description of problem:
When you "open" an RPM file (such as the last ghostscript all-in-one-package
update (why was it needed, BTW?)), the INFO/OBSOLETES file is always empty. The
/usr/lib/mc lists OBSOLETES, but doesn't provide a way to get it in the
mcrpmfs_copyout() function.

Version-Release number of selected component (if applicable):
4.5.55-5

Comment 1 Miloslav Trmac 2002-06-22 23:58:41 UTC
Created attachment 62244 [details]
Patch

Comment 2 Miloslav Trmac 2002-06-23 14:00:37 UTC
Note that the same fix has to be applied to /usr/lib/vfs/rpm, package gnome-vfs
(or possibly its equivalent in gnome 2). Don't you love duplicate files?

Comment 3 Miloslav Trmac 2002-10-05 23:41:34 UTC
The same in 8.0

Comment 4 Havoc Pennington 2002-10-06 00:05:12 UTC
Can you also submit this patch upstream, www.gnome.org/projects/mc? 
That way the maintainers of mc can review it, and it gets incorporated into 
the main mc version.

Comment 5 Paul Bolle 2003-07-10 21:17:10 UTC
Created attachment 92869 [details]
trivial patch to mc 4.6.0 (/usr/share/mc/extfs/rpm)

Still the same in 9.0 (using mc 4.6.0). 
 
INFO/LICENSE is always empty too. Since %{LICENSE} and %{COPYRIGHT} are always 
identical (AFAIK) and "License:" shows up after an "rpm -qi (...)" I suggest to
enable 
INFO/LICENSE and to drop INFO/COPYRIGHT. Please find attached my trivial patch
(also covering INFO/OBSOLETES).
 
I'll try to submit either my patch or a bugreport upstream and hope to return
here with an url (or 
something likewise).

Comment 6 Paul Bolle 2003-07-10 21:51:31 UTC
OK, here's the url of my upstreams bugreport: 
https://savannah.gnu.org/bugs/?func=detailbug&bug_id=4271&group_id=3521 (let's just hope it 
wasn't a duplicate report ...) 

Comment 7 Leonard den Ottolander 2004-05-09 13:14:19 UTC
Created attachment 100112 [details]
patch against mc-4.6.0-14.10

Easy fix and still not addressed. Please apply with the next update.

Comment 8 Leonard den Ottolander 2004-08-18 21:44:35 UTC
Yes yes, it's unbelievable but true: This has been fixed upstream!
Closing NEXTRELEASE as I assume this will be in one of the next releases.

Comment 9 Leonard den Ottolander 2004-08-22 11:02:59 UTC
Please also add this tiny patch before the next security update. TIA.


Comment 10 Leonard den Ottolander 2004-08-22 11:11:15 UTC
Created attachment 102966 [details]
Add INFO/OBSOLETES and INFO/LICENSE to rpm view

Comment 11 Leonard den Ottolander 2004-10-26 16:23:01 UTC
Fixed upstream and in RawHide.



Note You need to log in before you can comment on or make changes to this bug.