Bug 67344 - There's a typo somewhere
There's a typo somewhere
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
4.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-22 20:59 EDT by Zenon Panoussis
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-22 20:59:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2002-06-22 20:59:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
Compilation crashes like this:
       
/usr/src/redhat/BUILD/php-4.2.1/sapi/apache2filter/php_functions.c:93:27:
missing binary operator before '!'
make[3]: *** [php_functions.lo] Error 1
make[3]: Leaving directory
`/usr/src/redhat/BUILD/php-4.2.1/build-apache/sapi/apache2filter'
make[2]: *** [all-recursive] Error 1

Line 93 in php_functions.c reads:
#if !MODULE_MAGIC_AT_LEAST(20020506,0)

Looks like missing parentheses to me. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -ba php-4.2.1-2.spec on a 7.3 i386 machine with dependencies 
   from rawhide where needed.
	

Actual Results:  
/bin/sh /usr/src/redhat/BUILD/php-4.2.1/build-apache/libtool --silent
--mode=compile gcc  -I. -I/usr/src/redhat/BUILD/php-4.2.1/sapi/apache2filter
-I/usr/src/redhat/BUILD/php-4.2.1/build-apache/main
-I/usr/src/redhat/BUILD/php-4.2.1 -I/usr/include/apache2
-I/usr/src/redhat/BUILD/php-4.2.1/build-apache/Zend -I/usr/include/libxml2
-I/usr/include/freetype2/freetype -I/usr/include/imap -I/usr/include/mysql
-I/usr/local/include -I/usr/include/pspell -I/usr/include/ucd-snmp
-I/usr/src/redhat/BUILD/php-4.2.1/main -I/usr/src/redhat/BUILD/php-4.2.1/Zend
-I/usr/src/redhat/BUILD/php-4.2.1/TSRM  -D_REENTRANT
-I/usr/src/redhat/BUILD/php-4.2.1/build-apache/TSRM -O2 -march=i386 -mcpu=i686
-fPIC -pthread -DZTS -prefer-pic  -c
/usr/src/redhat/BUILD/php-4.2.1/sapi/apache2filter/php_functions.c
/usr/src/redhat/BUILD/php-4.2.1/sapi/apache2filter/php_functions.c:93:28:
missing binary operator before '!'
make[3]: *** [php_functions.lo] Error 1
make[3]: Leaving directory
`/usr/src/redhat/BUILD/php-4.2.1/build-apache/sapi/apache2filter'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
`/usr/src/redhat/BUILD/php-4.2.1/build-apache/sapi/apache2filter'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/php-4.2.1/build-apache/sapi'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.85121 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.85121 (%build)


Additional info:

Putting parentheses around that line did not solve the problem. Compile crashed
at the same place with the same error, thus I'm missing something here. Still,
the &%$#! thing does not compile.
Comment 1 Phil Copeland 2002-08-02 12:35:10 EDT
Version 4.2... erm you meant 7.3 didn't you...

Anyway for 7.3 the latest version of php is 4.1.2-7

4.2.x is really meant for the next release, but the current rawhide (4.2.2-2)
will compile fine on an up to date 7.3 box. (I verified that a few moments ago)

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.