This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 67349 - More on sendmail .spec file -- sendmail-8.12.4-1
More on sendmail .spec file -- sendmail-8.12.4-1
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: sendmail (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-06-23 00:33 EDT by R P Herrold
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 11:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2002-06-23 00:33:58 EDT
61270 has some unapplied parts which should be brought in as well, on libmilter 

[root@bo mail]# /usr/sbin/useradd -u 47 -d /var/spool/mqueue -r -s
/sbin/nologin  mailnull  || /usr/sbin/useradd -u 51 -d /var/spool/mqueue -r -s
/sbin/nologin smmsp
useradd: user mailnull exists
[root@bo mail]#
[root@bo mail]# ls -al /var/spool
total 478
drwxr-xr-x   12 root     root         1024 Jun 22 23:08 .
drwxr-xr-x   23 root     root         1024 Jun 21 22:46 ..
drwx------    3 daemon   daemon       1024 Jun 22 13:15 at
drwxr-xr-x    3 root     root         1024 Jun 22 10:58 autorpm
drwxrwx---    2 51       51           1024 Jun 22 22:25 clientmqueue
drwx------    2 root     root         1024 Jun 22 19:02 cron
drwxr-xr-x    2 root     root        12288 Dec 14  1999 lost+found
drwxr-xr-x    2 root     root         1024 Jun  1  2000 lpd
drwxrwxrwt    2 root     mail        29696 Jun 23 00:21 mail
drwx------    2 root     mail       434176 Jun 23 00:21 mqueue
drwxr-xr-x    2 uucp     uucp         1024 Feb  1 17:08 uucp
drwxr-xr-x    2 uucp     uucp         1024 Feb  1 17:08 uucppublic

I ran the install and for some reason it had not added  user:  smmsp  -- it
looks like it is stopping after the || -- which makes sense -- it should ALWAYS
execute both entries -- split it to two lines and it fixed the .spec file

So I re-ran it again to get it set up -- and confirmed the error

[root@bo mail]# chown smmsp.smmsp /var/spool/clientmqueue
chown: `smmsp.smmsp': invalid user
[root@bo mail]# grep smmsp /etc/passwd
[root@bo mail]# rpm -q sendmail
sendmail-8.12.4-1
[root@bo mail]# /usr/sbin/useradd -u 51 -d /var/spool/mqueue -r -s /sbin/nologin
smmsp

[root@bo mail]# grep smmsp /etc/passwd
smmsp:x:51:51::/var/spool/mqueue:/sbin/nologin


===============================

As a result also, the ownership on /var/spool/clientmqueue is not correct until
manually fixed

[root@bo mail]#  chown smmsp.smmsp /var/spool/clientmqueue
[root@bo mail]#

Hope this helps ...
Comment 1 Florian La Roche 2002-06-27 08:36:30 EDT
Hmmm, both look sane with the rawhide rpm. ?? Will double-check the next days
again.

Thanks,

Florian La Roche
Comment 2 R P Herrold 2002-08-08 11:34:33 EDT
rechecking in light of new Raw Hide releases ...

Seems to work cleanly for me:

[herrold@clone herrold]$ sudo rpm -Uvh
/usr/src/redhat/RPMS/i386/sendmail-8.12.5-5.i386.rpm
/usr/src/redhat/RPMS/i386/sendmail-doc-8.12.5-5.i386.rpm
/usr/src/redhat/RPMS/i386/sendmail-devel-8.12.5-5.i386.rpm
/usr/src/redhat/RPMS/i386/sendmail-cf-8.12.5-5.i386.rpm
chkconfig-1.3.5-4.i386.rpm ntsysv-1.3.5-4.i386.rpm
Preparing...                ########################################### [100%]
   1:chkconfig              ########################################### [ 16%]
   2:sendmail               warning: /etc/mail/access created as
/etc/mail/access.rpmnew
warning: /etc/mail/helpfile created as /etc/mail/helpfile.rpmnew
warning: /etc/mail/sendmail.cf created as /etc/mail/sendmail.cf.rpmnew
warning: /etc/mail/sendmail.mc created as /etc/mail/sendmail.mc.rpmnew
########################################### [ 33%]
warning: /etc/sendmail.cf saved as /etc/sendmail.cf.rpmsave
   3:sendmail-doc           ########################################### [ 50%]
   4:sendmail-devel         ########################################### [ 66%]
   5:sendmail-cf            ########################################### [ 83%]
   6:ntsysv                 ########################################### [100%]
[herrold@clone herrold]$ sudo service sendmail restart
Shutting down sendmail: [  OK  ]
Starting sendmail: [  OK  ]
Starting sm-client: [  OK  ]
[herrold@clone herrold]$ tail /etc/passwd /etc/group
==> /etc/passwd <==
phostetl:x:511:511::/home/phostetl:/bin/bash
windon:x:512:512::/home/windon:/bin/bash
obcc:x:513:513::/home/obcc:/bin/bash
jeff:x:514:514::/home/jeff:/bin/bash
michael:x:515:515::/home/michael:/bin/bash
ian:x:516:516::/home/ian:/bin/bash
mhess:x:517:517::/home/mhess:/bin/bash
r4:x:518:518::/home/r4:/bin/bash
whiteboard:x:519:519::/home/whiteboard:/bin/bash
smmsp:x:51:51::/var/spool/mqueue:/sbin/nologin

==> /etc/group <==
phostetl:x:511:
windon:x:512:
obcc:x:513:
jeff:x:514:
michael:x:515:
ian:x:516:
mhess:x:517:
r4:x:518:
whiteboard:x:519:
smmsp:x:51:
[herrold@clone herrold]$

===============

OK for a WORKS4ME close (or maybe a RAWHIDE one)

-- Russ

Note You need to log in before you can comment on or make changes to this bug.