Bug 67350 - plugger fails with realmedia
Summary: plugger fails with realmedia
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: plugger   
(Show other bugs)
Version: 7.3
Hardware: athlon Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-23 06:22 UTC by Florin Andrei
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-23 14:58:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florin Andrei 2002-06-23 06:22:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
I try to watch this page: http://news.com.com/2009-1001-937851.html and
click on the video links, but when realplayer starts, i always get this
message:

#######################################################
Invalid protocol specified in URL. URLs should typically start with
"rtsp://", "pnm://", or "http://"

/tmp/plugtmp/1604-2-937661-4.ram
#######################################################

It looks like RP expects an URL, but instead it gets a file name. Can
plugger be configured to send the URL instead of downloading the file
and feeding the file name to the player?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.go to http://news.com.com/2009-1001-937851.html
2.click on one of the realmedia links
3.
	

Actual Results:  Invalid protocol specified in URL. URLs should typically start with
"rtsp://", "pnm://", or "http://"

/tmp/plugtmp/1604-2-937661-4.ram

Expected Results:  realplayer should play the stream

Additional info:

These are my actual plugins:

[root@rivendell root]# ls -l /usr/lib/mozilla-1.0.0/plugins/
total 1092
-rwxrwxr-x    1 root     root       948056 Mar 25 10:17
libflashplayer.so
lrwxr-xr-x    1 root     root           61 Jun 21 20:53
libjavaplugin_oji.so ->
/usr/java/j2re1.4.0_01/plugin/i386/ns610/libjavaplugin_oji.so
-rwxr-xr-x    1 root     root        18276 Jun  6 06:54 libnullplugin.so
lrwxr-xr-x    1 root     root           36 Jun 21 20:57 plugger.so ->
/usr/lib/netscape/plugins/plugger.so
-r--r--r--    1 root     root         4139 May 18  2001 raclass.zip
-r-xr-xr-x    1 root     root       131580 May 18  2001 rpnp.so
-r--r--r--    1 root     root         2363 Mar 25 10:18
ShockwaveFlash.class
[root@rivendell root]#

Even if i remove raclass.zip and rpnp.so and restart the browser, the
result is the same.

If i add back those two plugin files, but remove plugger.so, i get a
page with the Real Player swallowed, but the player does not start.

Comment 1 Ngo Than 2002-06-23 17:09:39 UTC
The config file pluggerrc has a bug which is fixed now in next release.

There is here a another bug in realplayer plugin, it does not play the stream!
i cannot fix this bug in this case. Please ask realnetworks about new version.


Note You need to log in before you can comment on or make changes to this bug.