Bug 67366 - (IDE)new error messages with Athlon 2.4.18-5
(IDE)new error messages with Athlon 2.4.18-5
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-23 13:39 EDT by baulv
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-27 18:19:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/dmesg (8.34 KB, text/plain)
2002-06-23 13:50 EDT, baulv
no flags Details

  None (edit)
Description baulv 2002-06-23 13:39:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
new error messages on bootup not seen in Athlon 2.4.18-4
realting to IDE drives

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install kernel 2.4.18-5 w/ up2date
2.reboot
3.look at bootup messages
	

Actual Results:  Jun 23 12:36:49 w1 kernel: hda: dma_intr: status=0x51 {
DriveReady SeekComplete Error }
Jun 23 12:36:49 w1 kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }

Expected Results:  none of the above errors

Additional info:

the hdd seems to work Ok. 

ASUS A7V333
Comment 1 baulv 2002-06-23 13:50:59 EDT
Created attachment 62264 [details]
/var/log/dmesg
Comment 2 Arjan van de Ven 2002-06-24 08:33:23 EDT
Jun 23 12:36:49 w1 kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }

ehm that's a cable problem!
Comment 3 baulv 2002-06-25 20:44:25 EDT
ehm... and it still works?
  The old 2.4.18-4 kernel did not seem to mind my cable?
I'll reseat it and report back.

Comment 4 baulv 2002-06-25 21:33:30 EDT
OK. cable was fine. But your ide(a) of cabling made me think. 
The the two drives I have on the primary IDE channel uses Cable SELect. 

When I changed the Cable SELect on both to MASTER and SLAVE respectively, the
boot up error message disappeared.

Comment 5 baulv 2002-06-26 19:13:55 EDT
oops, the messages are back...
Jun 26 19:00:31 w1 kernel:   ROM checksum self-test: passed (0x3258698e).
Jun 26 19:00:31 w1 kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete
Error }
Jun 26 19:00:31 w1 kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jun 26 19:00:31 w1 kernel: hda: dma_intr: status=0x51 { DriveReady SeekComplete
Error }

Jun 26 19:00:31 w1 kernel: hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
Jun 26 19:00:32 w1 apmd[861]: Charge: * * * (-1% unknown)


I'll try another cable.
Comment 6 Pawel Salek 2002-08-24 12:32:06 EDT
This is not a problem with a IDE cable. It is a problem with RH patches on top
of stock kernel, as far as I can tell - see #71545.
Comment 7 Pawel Salek 2003-03-18 07:21:15 EST
bug #71545 has been fixed and this may be closed as well (I seem not to have
right to do that).
Comment 8 Brian Bothwell 2003-06-03 11:54:16 EDT
I have a box with a WDC WD1000JB-00CRA1 100GB drive, and a VIA chipset, and have
been getting these same errors once we upgraded to Redhat 7.3.  After much
futzing (BIOS uogrades, disabled cable-select, etc.) I upgraded to Redhat 8.0
and the errors still occur:

hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
hda: dma_intr: error=0x84 { DriveStatusError BadCRC }
(thousands of these a day)

However, there are two things I can do to reduce/stop these messages, but nither
is fully acceptible:

1) force the WD drive to run in UDMA/33 mode (instead of UDMA/66).  This reduces
the errors to a handful a day, but cuts the performance from around 32MB/s to
around 26MB/s.

2) disable DMA (hdparm -d 0 /dev/hda). This stops the errors, but cuts the
performace down to around 6MB/s, ugh!!


This is very frustrating. :(  


Here are the vitals:
--------------------

[root@sparky rc3.d]# uname -a
Linux sparky 2.4.20-13.8 #1 Mon May 12 11:48:50 EDT 2003 i686 athlon i386 GNU/Linux



 [root@sparky rc3.d]# /sbin/lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] System
Controller (rev 25)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] AGP Bridge
(rev 01)
00:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 1b)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 0e)
00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 20)
01:05.0 VGA compatible controller: ATI Technologies Inc Rage 128 RF/SG AGP

-------------
[root@sparky rc3.d]# /sbin/hdparm -i /dev/hda


dev/hda:

 Model=WDC WD1000JB-00CRA1, FwRev=17.07W17, SerialNo=WD-WMA8C3239128
 Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
 RawCHS=16383/16/63, TrkSize=57600, SectSize=600, ECCbytes=40
 BuffType=DualPortCache, BuffSize=8192kB, MaxMultSect=16, MultSect=16
 CurCHS=17475/15/63, CurSects=16513875, LBA=yes, LBAsects=195371568
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 *udma4
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: device does not report version:  1 2 3 4 5



Comment 9 Alan Cox 2003-06-27 18:19:55 EDT
The original bug seems sorted. The later VIA report is unrelated and seems to be
hardware noise.


Note You need to log in before you can comment on or make changes to this bug.