Bug 67372 - Driver serveraid (ips.c ) : syntax error and link time problem
Driver serveraid (ips.c ) : syntax error and link time problem
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-23 16:37 EDT by Need Real Name
Modified: 2007-03-26 23:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:57:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-23 16:37:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Kernel  2.4.18-4

Enabling SCSI serveraid support not as module there is a syntax error in file 
ips.c  line :547. With some quick checking I have found a misplacement of a 
brace "}". (diff file attached)  

After removed this error there is another problem during final linking :

scsidrv.o .... undefined reference to `local symbols in
discarded section .text.exit'

Checking again the code I have found the cause in a function marked as 
__devexit that is not properly handled when build not as a module.

I have patched this point also whit a rather quick and dirty workaround and now 
the kernel is running nicely.


Version-Release number of selected component (if applicable):  2.4.18-4


How reproducible:
Always

Steps to Reproduce:
1. build the kernel setting serveraid as built-in (not module)
2.
3.
	

Additional info:

diff ips.c  ips.c.orig

287d286
< #ifdef MODULE         
289d287
< #endif              
548c546
< }
---
> 
584,585d581
< }
< #endif
586a583
> #endif
587a585
> }
Comment 1 Arjan van de Ven 2003-06-07 14:57:40 EDT
fixed in current erratum

Note You need to log in before you can comment on or make changes to this bug.