Bug 67378 - kpackage crashes on uninstalling certain packages
kpackage crashes on uninstalling certain packages
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdeadmin (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-23 19:14 EDT by baulv
Modified: 2007-04-18 12:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 18:06:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tracebackfile (3.74 KB, text/plain)
2002-06-23 19:15 EDT, baulv
no flags Details
tracebackfile (3.74 KB, text/plain)
2002-06-23 19:16 EDT, baulv
no flags Details
tracebackfile (4.26 KB, text/plain)
2002-06-23 19:19 EDT, baulv
no flags Details
strace of kpackeage (52.42 KB, text/plain)
2002-06-25 20:27 EDT, baulv
no flags Details

  None (edit)
Description baulv 2002-06-23 19:14:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
kpackage crashes on uninstalling certain packages, some not

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.open kpackage (as root)
2.select package to be uninstalled
3.click on uninstall button
	

Actual Results:  application crashes 

Expected Results:  application should not crash:)


Additional info:
Comment 1 baulv 2002-06-23 19:15:26 EDT
Created attachment 62304 [details]
tracebackfile
Comment 2 baulv 2002-06-23 19:16:56 EDT
Created attachment 62305 [details]
tracebackfile
Comment 3 baulv 2002-06-23 19:19:04 EDT
Created attachment 62306 [details]
tracebackfile
Comment 4 Warren Togami 2002-06-24 04:34:38 EDT
Could you please check if this is equivalent to the behavior reported in Bug 66956?
Comment 5 baulv 2002-06-24 23:27:23 EDT
It may be.
 I also had problems at times with "rpm -e <packagename>" followed by
"rpm -q <thatpackagenameIjust-e'd> in listing it still was there.

"[root@w1 zip]# rpm -Uvh   xforms-0.88.1.KSI2-3.i686.rpm
Preparing...                ########################################### [100%]
   1:xforms                 ########################################### [100%]

[root@w1 zip]# rpm -e xforms-0.88.1.KSI2-3.i686.rpm
error: package xforms-0.88.1.KSI2-3.i686.rpm is not installed
[root@w1 zip]# rpm -e xforms-0.88.1.KSI2-3.i686.rpm
error: package xforms-0.88.1.KSI2-3.i686.rpm is not installed
[root@w1 zip]# rpm -q xform
package xform is not installed
[root@w1 zip]# rpm -Uvh xforms-0.88-9.i386.rpm
Preparing...                ########################################### [100%]
package xforms-0.88.1.KSI2-3 (which is newer than xforms-0.88-9) is already
installed"


I don't know if "rpm -rebuilddb" and "rpm -initdb" will help? 




Comment 6 Warren Togami 2002-06-25 00:09:38 EDT
This line:
 [root@w1 zip]# rpm -q xform
should be:
 [root@w1 zip]# rpm -q xforms

Verify that the installation was successful by querying that package info with
"rpm -qi xforms".
Does that take care of that problem?

Also can you please test the specific behavior reported in Bug 66956 to see if
that causes the kpackage crash?  The bug cannot possibly be fixed if it cannot
be isolated.
Comment 7 baulv 2002-06-25 20:27:29 EDT
Created attachment 62645 [details]
strace of kpackeage
Comment 8 baulv 2002-06-25 20:31:18 EDT
Ok, "xform" my bad. Should have been "xforms" works fine.

Kpackage de-install of "mysql" and "mysql-server" was uneventful.
Trying to de-install "gnome-pilot" and "pilot-link" I get a crash.
From the "strace" and the console debug messages it looks like unresolved
dependencies that are not reported by "kpackage".
Even a "query" results in a Krash.

Comment 9 Ngo Than 2004-10-11 18:06:18 EDT
kpackage has been removed since rhel3. please report bugs directly to
bugs.kde.org. Thanks

Note You need to log in before you can comment on or make changes to this bug.