Bug 67398 - build_gcc_31 and build_gcc_31_primary cannot be unset
Summary: build_gcc_31 and build_gcc_31_primary cannot be unset
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-24 13:52 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 20:12:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-06-24 13:52:30 UTC
Description of Problem:
I am trying to build openoffice on RedHat 7.3 by disabling build_gcc_31 and
build_gcc_31_primary without success...

Version-Release number of selected component (if applicable):
RedHat 7.3
OpenOffice_1.0.0-1

How Reproducible:
1. Change the spec file as follow:

[root@papeete SPECS]# diff openoffice-1.0.spec.org  openoffice-1.0.spec
9c9
< %define build_gcc_31 1
---
> %define build_gcc_31 0
13c13
< %define build_gcc_31_primary 1
---
> %define build_gcc_31_primary 0


2. rpm -ba openoffice-1.0.spec 


Actual Results:
[root@papeete SPECS]# rpm -ba openoffice-1.0.spec
error: parse error in expression
error: /usr/src/redhat/SPECS/openoffice-1.0.spec:116: parseExpressionBoolean
returns -1
error: Package has no %description: openoffice

Expected Results:
Build of OpenOffice 1.0 with gcc-2.96

Comment 1 David Juran 2002-06-27 23:21:05 UTC
I believe this really is a bug in rpm and it seems to me it is a duplicate of 65719


Note You need to log in before you can comment on or make changes to this bug.