Bug 674000 - xen-devel not installable in Rawhide
xen-devel not installable in Rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-31 04:53 EST by Richard W.M. Jones
Modified: 2011-02-01 07:32 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-01 07:32:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2011-01-31 04:53:31 EST
Description of problem:

DEBUG util.py:247:  ERROR with rpm_check_debug vs depsolve:
DEBUG util.py:247:  libblktap.so.3.0()(64bit) is needed by xen-devel-4.0.1-8.fc15.x86_64
DEBUG util.py:247:  libvhd.so.1.0()(64bit) is needed by xen-devel-4.0.1-8.fc15.x86_64

(see whole log here:
http://koji.fedoraproject.org/koji/getfile?taskID=2751990&name=root.log )

This prevents you building packages against libvirt-devel
amongst other things.

Please fix this as I cannot build libguestfs and it will
block many other packages soon.

Version-Release number of selected component (if applicable):

xen-devel-4.0.1-8.fc15.x86_64
Comment 1 Michael Young 2011-01-31 05:23:45 EST
This could be a glitch in the build system as the update from 4.0.1-6 to 4.0.1-8 hasn't essentially changed the code it is built from so these libraries should be in xen-libs both before and after the update. One of the reasons I did the update was a buildsys warning about libpci, which on closer examination hadn't changed version but did have an update around that time.

Note that my plan is to update to xen-4.1.0 when it comes out. I have done some scratch builds of the release candidates, but nothing in rawhide yet, though I could do so if you think that would be useful.
Comment 2 Michael Young 2011-01-31 11:39:04 EST
I have work out what the problem is. It seems under the new rpm that libraries have to be executable or else they are left out of the provides list. I will try to get this fixed and do a rebuild tonight.
Comment 3 Michael Young 2011-01-31 14:52:01 EST
I have built 4.0.1-9 in rawhide which should fix this problem.
Comment 4 Richard W.M. Jones 2011-02-01 07:32:05 EST
Thanks, appears to be fixed by
http://koji.fedoraproject.org/koji/buildinfo?buildID=216396

Note You need to log in before you can comment on or make changes to this bug.