Bug 67409 - Bad: Installation cancels
Bad: Installation cancels
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-24 13:00 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-28 07:49:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the dump file of the failed installation of the 7.3 Pro (125.33 KB, text/plain)
2002-06-25 09:02 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-06-24 13:00:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Windows NT 5.0; U)

Description of problem:
Bad: Installtion quits on the 3rd disk, however, media checks out okay

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start installion of update from RH 7.2 Personal to RH 7.3 Professional.
2. Ask me to put in second CD continues to run until the last part of the 2nd CD.
3. 
	

Actual Results:  Error message: An unhandled exception has occured

Expected Results:  continue with 3rd CD

Additional info:

This had been documented with support under inscident number 208258 on 22 June.  My 60 days is about to expire and I still haven't got the new 
RH 7.3 Professional updated and running on my computer.  (Not real happy about this)  This is a duel boot system.  Media checks out. I have the 
dump file, however it was also sent to RH support, which should be available under the inscident number above.
Comment 1 Jeff Johnson 2002-06-24 13:04:48 EDT
This smells like an anaconda, not rpm, problem.
Comment 2 Need Real Name 2002-06-24 13:10:33 EDT
I see you think this is anaconda.  This was reported under support incident 
208258.  Yes, we checked this out too.  Maybe both?  I started anaconda under 
linux noaltheon, linux mem = nopentium, and also in the text mode all failed 
the same way.
Comment 3 Need Real Name 2002-06-25 09:02:57 EDT
Created attachment 62504 [details]
This is the dump file of the failed installation of the 7.3 Pro
Comment 4 Need Real Name 2002-06-25 09:22:30 EDT
To msf@redhat.com
I thought I would include a copy of my Service Request for reference.
Peace,
Marsie
________________________________________________________________________________
Service Request: 208258
MARSIE SIMOPOULOS (396023)
****************************************************************************
Date 		Action 			Contact 	Attachment 
****************************************************************************
Technician Response
22-JUN-2002 05:25:17 EST Notify Customer with e-mail notification. Philip  
Dear Sir/Madam,
This may already be a possible bug. I strongly suggest that you address this
directly to our developers, they are the ones responsible on working on new
issues and possible bugs. You can get in touch with them through our bugzilla
site:
http://bugzilla.redhat.com/
Regards,
Philip
****************************************************************************
Customer Request 
21-JUN-2002 16:27:01 EST Request Updated 		Simopoulos, Marsie 
 <javascript:document.form363609.submit();>A:\anacdump.txt 
<javascript:document.form363609.submit();> 
Hi Michael,
I have checked the installation disks and all three checked out.
Peace,
Marsie

The error window says:
An unhandled exception has occured.  This is likely a bug.  Please copy the
full text of this
exception or save teh crash dump to floppy
Then file a detailed bug report against anaconda at
http://bugzilla.redhadt.com/bugzilla/

I quickly wrote down what was below, but I don't know how accurate this is,
because of my handwriting.

File "/usr/bin/anaconda"line 633 in?
  intf.run (id, dispatch,configFileData)
File "/usr/bin/anaconda/gui.py", line 353, in run
  self.ilw.run (self.runres, configFileData)
File "/usr/bin/anacond/gui.py". line 814, in run
  mainloop()
File "/usr/lil/pytheon 1.5/site-package/gtk.py", line 2676, in mainloop
  _gtk.gtk_main()
File "/usr/bin/anaconda/gui.py" line 529, in handleRenderCallback
  Self, curewtwindow.redercallback()
File "/usr/bin/anaconda/iw/progress_gui.py", line 135 in rendercallback
  self.intf.icw.nectClicked()
File "/usr/bin/anaconda/gui.py", line 417 in nextClicked
    self.dispatch.gotoNext()
File "/usr/bin/anaconda/dispatch.py", line 144, ingotoNext
  self.morestep()
File "/usr/bin/anaconda/dispatch.py", line 209, inmoveStep
  rc=apply(tunc, self.bindArgs(args)
File "/usr/bin/anaconda/package.py", line 611, in dolustall
  problem = ts.run(0, ~rpm.RPMPROB_FILTER_DISPACE, cb.cb, 0)
File "/usr/bin/anaconda/packages.py", line 244, in cb
  fn = self.method.getFilename(h, self.pkgTimer)
File "/usr/bin/anaconda/image.py", line 86, in getfilename
  isys.unmount("/mnt/source")
File "/usr/bin/anaconda/isys.py", line 171, in umount
  rc = _isys.unmount(what)
system error:(16, Device or resouce busy)

****************************************************************************
Technician Response 
21-JUN-2002 15:42:24 EST Notify Customer with e-mail notification. Michael 
Dear Mam,
To sum up what we have discussed on the phone, you where able to save the bug
message to a floppy disk which was asked during the installation.  Also, you
mentioned that you encountered a "missing files or bad media..." error.

With that, please use the boot option below once the "boot:" prompt shows up to
perform a media check:

linux mediacheck

Furthermore, please attach to this service request the error message you have
encountered.

Feel free to write us back.

Regards,
Michael

****************************************************************************
Technician Response 
21-JUN-2002 14:06:00 EST Notify Customer with e-mail notification. Gian Paulo 
Dear Madam,
Another parameter that you can add to the boot prompt is:

  linux text

This will do a text mode installation which sometimes solves some installation
issues.  You can add the "text" parameter to other commands.  Here's an example
of the one we did:

  linux mem=nopentium text

Once again, we ended the call on the package installation of your installation
proccess.  If you do run into errors, please check your error messages by
pressing:

  Ctrl-Alt-F3
  or 
  Ctrl-Alt-F4

If you still run into installation problems, please feel free to create a
ticket or give us a call.

Regards,
Paulo Ng

****************************************************************************
Technician Response 
21-JUN-2002 13:01:00 EST Notify Customer with e-mail notification. Michael 
Dear Madam,
To sum up what we have discussed on the phone, please use any of the boot
option below once the "boot:" prompt shows up:

linux noathlon

linux mem=nopentium

Also, please check the other consoles for error or installation messages:

Press "ctrl" "alt" "F3" simultaneosuly
Press "ctrl" "alt" "F4" simultaneosuly

To go back at the installation screens:

Press "ctrl" "alt" "F1" simultaneosuly
Press "ctrl" "alt" "F7" simultaneosuly

Feel free to write us back.

Regards,
Michael Napolis

****************************************************************************
Customer Request 
21-JUN-2002 12:40:40 EST Problem Description 	Simopoulos, Marsie 
I'm trying to upgrade from 7.2 to 7.3 but it hangs up when trasferring the
packages; i have a amd processor...
****************************************************************************
****************************************************************************
Comment 5 Need Real Name 2002-06-27 07:52:11 EDT
This was done under the trouble ticket 208258 as stated above. : )
Peace,
Marsie
Comment 6 Need Real Name 2002-06-27 07:53:03 EDT
Just for fun I'll try it again?
Peace,
Marsie
Comment 7 Need Real Name 2002-06-27 08:05:57 EDT
Just for fun I'll try it again?
Peace,
Marsie
Comment 8 Need Real Name 2002-06-28 07:49:30 EDT
Hi Bugzilla,
Is anyone working on this problem?  
I need this system up and running this weekend to do some real work.
Peace,
Marsie
Comment 9 Michael Fulbright 2002-07-09 21:13:53 EDT
Your CD(s) are bad, as indicated by these errors in the log file:

<4>hdc: irq timeout: status=0xd0 { Busy }
<4>hdc: ATAPI reset complete
Comment 10 Need Real Name 2002-07-10 07:36:53 EDT
Hi Bugzilla,
Will I have to purchase new ones?
Peace,
Marsie
Comment 11 Need Real Name 2002-07-10 07:38:37 EDT
Hi Again Buzilla,
I was wondering why the check of the media was done and it came out okay, but 
you are now saying they are bad?
Peace,
Marsie

Note You need to log in before you can comment on or make changes to this bug.