Bug 67453 - rhn_register crashes, /usr/share/rhn/RHNS-CA-CERT not accessible
rhn_register crashes, /usr/share/rhn/RHNS-CA-CERT not accessible
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rhn_register (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-25 11:09 EDT by Cipriano Groenendal
Modified: 2015-01-07 18:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 17:32:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cipriano Groenendal 2002-06-25 11:09:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
When running rhn_register for the first time, without up2date-*.rpm installed, 
rhn_register will crash because the file /usr/share/rhn/RHNS-CA-CERT  does not 
exist.
The rpm should depend on up2date

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. uninstall up2date
2. install rhn_register
3. run rhn_register
4. press enter when it asks about proxy/network setup
	

Actual Results:  The program crashed because it couldn't find the file

Additional info:

Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 183, in ?
    main()
  File "/usr/sbin/rhn_register", line 164, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1042, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 986, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 45, in __init__
    tb = snack.Textbox(size[0]-10, size[1]-14, rhnreg.welcomeText(), 1)
  File "/usr/share/rhn/register/rhnreg.py", line 433, in welcomeText
    return doCall(s.registration.welcome_message)
  File "/usr/share/rhn/register/rhnreg.py", line 153, in doCall
    ret = apply(method, args)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 689, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 746, in __request
    self.__protocol
  File "/usr/lib/python1.5/site-packages/xmlrpclib.py", line 631, in request
    req.use_CA_chain(self.__ca_chain)
  File "/usr/lib/python1.5/site-packages/cgiwrap.py", line 539, in use_CA_chain
    raise IOError, "the CA cert %s was not accessible" % ca_chain
IOError: the CA cert /usr/share/rhn/RHNS-CA-CERT was not accessible
Comment 1 Adrian Likins 2002-06-25 11:34:38 EDT
Hmm, that file should probabaly be owned by both packages. Or
both packages should be combined into one.

Note You need to log in before you can comment on or make changes to this bug.