Bug 674617 - torque.setup should be executable
torque.setup should be executable
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: torque (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Traylen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-02 11:32 EST by Fabien Archambault
Modified: 2011-03-13 04:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-13 04:20:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fabien Archambault 2011-02-02 11:32:32 EST
Description of problem: I think in the package torque the file /usr/share/doc/torque-2.4.11/torque.setup should be executable.


Version-Release number of selected component (if applicable): torque-2.4.11-1.fc14.x86_64


How reproducible: always

Steps to Reproduce:
1. # /usr/share/doc/torque-2.4.11/torque.setup root
-bash: /usr/share/doc/torque-2.4.11/torque.setup: Permission denied
  
Additional info:
This is a shell script so it sohould be chmod +x
Comment 1 Steve Traylen 2011-02-02 11:39:19 EST
Hi Fabien,

The immediate answer is it should not be since it's a  document.

http://fedoraproject.org/wiki/PackagingGuidelines#Documentation

but I'll take a look and if its useful, i confess I have never used it , I will move it else
where so it can be made +x.

Thank

Steve.
Comment 2 Fabien Archambault 2011-02-02 11:46:08 EST
Hi,

I agree with you it is weird that this file is in the documentation and is a shell script.
I was trying to follow that tutorial to setup the pbs_nodes on my computers : http://dvbmonkey.wordpress.com/2009/02/27/getting-started-with-open-mpi-on-fedora

This is why I asked it to be executable but the Guidelines say the opposite. Perhaps should we notice upstream?
Comment 3 Steve Traylen 2011-02-02 14:01:16 EST
I took a look at the torque.setup.

I did add a README.Fedora which was my solution.

I don't think torque.setup should really be added in /usr/sbin or anything
mainly because you only ever run it once and it could actually break
running setups.

If you want to run it just prefix it with

bash torque.setup

As for the web page it is referring to rather old 2.1.4 when I expect
the %doc was executable.

I would leave a comment on the blog page with the fix but it's hopefully
fairly obvious.

What do you think?

Steve.
Comment 4 Fabien Archambault 2011-02-02 14:08:43 EST
Consideringthe blog page things have changed since it was written like /var/torque changed into /var/lib/torque.
Considering the executable of this file I would think we stay as we are actually as it is in the guidelines of Fedora.

I totally agree not to put it in the /usr/sbin.

Thanks for taking your time to answer. You can close as not a bug.

Note You need to log in before you can comment on or make changes to this bug.