Bug 674840 - Please fix meshmagick to build with ogre 1.7
Summary: Please fix meshmagick to build with ogre 1.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: meshmagick
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bruno Wolff III
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-03 14:01 UTC by Bruno Wolff III
Modified: 2011-03-11 06:10 UTC (History)
2 users (show)

Fixed In Version: meshmagick-0.6.0-8.svn2898.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-11 06:10:21 UTC


Attachments (Terms of Use)

Description Bruno Wolff III 2011-02-03 14:01:52 UTC
Description of problem:
meshmagick has a dependency error in rawhide and will not install with the 1.7 ogre. Upstream has incorporated changes so that it will build with ogre 1.7.1.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Bruno Wolff III 2011-02-03 14:03:16 UTC
I forgot to give a heads up. Like most of the rest of the Ogre stuff, the license changed to MIT.

Comment 2 Bruno Wolff III 2011-02-20 22:48:34 UTC
I am still working on this, but in case anyone else starts looking, it looks like we need to use cmake instead of autotools to do the building. That means double checking that libraries aren't statically linked and that there is no rpath stuff. In addition it looks like some of the supplementary files may have moved.
I did a local test build that got past the linking issue, so this looks promising, but I am not ready to kick off a real build yet.

Comment 3 Bruno Wolff III 2011-02-21 03:19:02 UTC
I'm almost there. Multilib on x86_64 isn't working right yet, but it's building on i686.

Comment 4 Fedora Update System 2011-03-06 19:14:38 UTC
meshmagick-0.6.0-8.svn2898.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/meshmagick-0.6.0-8.svn2898.fc15

Comment 5 Fedora Update System 2011-03-07 01:31:39 UTC
meshmagick-0.6.0-8.svn2898.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update meshmagick'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/meshmagick-0.6.0-8.svn2898.fc15

Comment 6 Fedora Update System 2011-03-11 06:10:17 UTC
meshmagick-0.6.0-8.svn2898.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.