Bug 67489 - Unable to allocate colors (8 bit/motif)
Summary: Unable to allocate colors (8 bit/motif)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-06-26 09:28 UTC by Need Real Name
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-26 09:45:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Program to test the color allocation (219.81 KB, application/octet-stream)
2002-06-26 09:42 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-06-26 09:28:28 UTC
Description of Problem:
Our inhouse-made programs need full control over the colors used, and 
therefore uses 8 bit colordepth and allocation of the colors wanted. When 
upgrading to RH7.3 our programs can no longer do this. The method 
XAllocColor() fails, and the colors we then get is all weird. The odd thing 
is when I forcely installs XFree-4.1.0-25 and XFree-libs-4.1.0-25, the 
allocation is ok again.


Version-Release number of selected component (if applicable):
4.2.0-8

How Reproducible:
Every time

Steps to Reproduce:
1. Run X with mwm (motif window manager)
2. Start the attached program
3. 

Actual Results:
The program is unable to allocate colors

Expected Results:
The program should be able to allocate colors


Additional Information:
The attached file can also be found:
www.navtek.no/~johnny/xfree
or
193.220.102.195/~johnny/xfree

Comment 1 Need Real Name 2002-06-26 09:42:57 UTC
Created attachment 62685 [details]
Program to test the color allocation

Comment 2 Mike A. Harris 2002-07-10 02:40:42 UTC
This problem is due to the Render extension.  The Render extension consumes
a large portion of the colormap entries in 8 bit depth.  XFree86 CVS code
has modified Render to not be as aggressive with the colormap entries, so
a future release of XFree86 4.3.0 should be much better.

The recommended workaround for now, is to use 24bit depth with an 8 bit
overlay.  This requires video hardware that supports this configuration.

There is no current plan to backport the 4.3.0 Render code to 4.2.0, so
users are recommended to use the above workaround, or to use different
video hardware in the interim that support overlays.  Alternatively one
can fall back to 4.1.0, or try XFree86 CVS.

I'm closing this as WONTFIX, since there is no bugzilla resolution for
FIXED_UPSTREAM for future release.



Note You need to log in before you can comment on or make changes to this bug.