Bug 67550 - redhat-config-network crashes on attempt to save changes
redhat-config-network crashes on attempt to save changes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-27 07:14 EDT by Matt Palmer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-27 07:14:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Palmer 2002-06-27 07:14:40 EDT
Description of Problem:redhat-config-network crashes on attempt to save 
changes, this only happened since applying a bug fix to mend the 'Save changes 
bug'


Version-Release number of selected component (if applicable):


How Reproducible:every time


Steps to Reproduce:
1. in KDE open network configuration, attempt to make any change
2. close window and say yes to save

Actual Results:network configurator crashes with bug check message


Expected Results:should save changes made to any of the fields under any of 
the displayed tabs.


Additional Information:
Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File 
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", line 
276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 
981, in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 
936, in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
endofline: None
value: {'alias': None}
self: <netconfpkg.NCHardwareList.MyConfModules instance at 847de10>
varname: eth1
missing: 1
key: alias
place: 0
findexp: [       ]*alias[        ]+eth1[         ]+
Comment 1 Harald Hoyer 2002-07-01 05:49:32 EDT
fixed in redhat-config-network > 1.0.0

Note You need to log in before you can comment on or make changes to this bug.